ALLBOT Scratch Sketch Failing


#1

I am going through the scratch installation instructions that I found here:

https://manuals.velleman.eu/article.php?id=457

My machine is a Windows 7 64-bit
The arduino for the ALLBOT comes in as port 46 when connected to my PC.
I get the following error when I attempt to upload the scratch.
Any suggestions?

Thanks very much in advance.


In function ‘operator delete []’,

inlined from '__base_dtor ' at C:\Program Files (x86)\Arduino\libraries\ALLBOT\SerialALLBOT.cpp:13:11,

inlined from '__static_initialization_and_destruction_0(int, int) [clone .part.0] [clone .constprop]' at C:\Users\jlichten\Documents\Scratch programming for ALLBOT\Arduino\Sketch\VR204Scratch\VR204Scratch.ino:12:14,

inlined from '__static_initialization_and_destruction_0.constprop',

inlined from '_GLOBAL__sub_D_BOT' at C:\Users\jlichten\Documents\Scratch programming for ALLBOT\Arduino\Sketch\VR204Scratch\VR204Scratch.ino:284:1:

C:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino\new.cpp:34:12: warning: attempt to free a non-heap object ‘BOT’ [-Wfree-nonheap-object]

free(ptr);

        ^

Sketch uses 10704 bytes (33%) of program storage space. Maximum is 32256 bytes.
Global variables use 548 bytes (26%) of dynamic memory, leaving 1500 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can’t open device “\.\COM46”: The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.


#2

It seems it can’t open the port.

Have you tried reconnecting the allbot with the PC?
And make sure no other program is using the port. (ex. Scratch4Allbot program)
Also make sure the switch on the servo shield is on “program”

Best Regards
VEL337