Allbot takes 2 Ampere for moving all 4 legs in the air


i have a problem with my brand new Allbot with 4 legs. I took 4 Alkali Batteries from Alsmann and saw that the Allbot can’t take his own. It tries, but not all legs come. When holding it in the air, everything looks good.
Then i tried my rechargeable eneloop Akkus form my Digicam. Same. After that i went do my local electronic Market and got 4 brand new Alkali Varta Max Tech. It worked fine - for about half a Minute… :frowning:

So our next step was measure the voltage. When the legs are all moving (i have the Demo program on it) and the legs from the bot are in the air it takes 2 Ampere. Don’t know if it is okay, or not. Can anyone figure out, what his bot is taking?

I’m using the Arduino Mega shield and in my package there was one Servo damaged, what i found out, when i set them to their zero position. I took another one that i has from an additional leg. Maybe there ist something wrong with one of my shields? How can i figure out this?
How long are your bots working with batteries oder Akkus?