Boring interruptions on K8800

The printer prints a few layers, then breaks the print with “Filament change”. This happens at any time. Have tried in “Repetier Host” V2.05 and with SD card, always the same problem. I also updated “Firmware” without the problem disappearing. Have tried other filaments and different models with the same results. Also changed “nozzle” (0.35), but no difference.
In Repetier Host log I can see that command M600 is send, but the G-code does not contain M600!!!

Cut from logfile: < 10:24:27.861 : N80235 G1 X-16.631 Y-5.089 E0.1097*102

10:24:27.861 : echo:enqueueing “M600”
10:24:28.236 : ok
< 10:24:28.236 : N80236 M105*40
10:24:28.236 : ok

Can someone help me?

The log you posted shows an “echo” line referencing M600, but “echo” merely prints to the console, and does not actually command the printer to do anything.

Could it be that your filament detector is malfunctioning? These can be finicky. If the printer believes the filament has run out, it might be pausing for a reload.

The other possibility is that you have sliced the model with instructions to pause for a filament change at certain layers? (This is sometimes done to facilitate a color change mid-print.)

Thanks for your responce. How can I check the filament detector?
No I did not use the change-at-layer feature of Simplify3D. I will continue testing before ordering a new detector…


You can disconnect it.
See this link for instructions

1 Like