Calibration failure EDU09


#1

Calibration results:

CH1 offset at 2V/div : 179 FAIL
Rounds : 51
CH1 offset at 1V/div : 56 FAIL
Rounds : 51
CH1 Y-position low, CH1_DAC1 0 83
Rounds : 51
CH1 Y-position mid, CH1_DAC0 0 179
Rounds : 51
CH1 Y-position high, CH1_DAC2 0 255
Rounds : 32

What is causing the failure?


Edu09 calibration failed
#2

I found that the ic chips were not fully in and here is the results after pushing them in

Calibration results:

CH1 offset at 2V/div : 77 FAIL
Rounds : 51
CH1 offset at 1V/div : -46 OK
Rounds : 51
CH1 Y-position low, CH1_DAC1 202 0
Rounds : 33
CH1 Y-position mid, CH1_DAC0 202 77
Rounds : 51
CH1 Y-position high, CH1_DAC2 202 255
Rounds : 32


#3

Voltages at position
A= 1.67V
B=0.454V
C=4.3V
D=3.007V
E=-2.6V
F=-5.2V


#4

Please check that there is -5.2V on pin 4 of IC2.
Also make sure that the orientation of IC2 is correct:


#5

Thank you for the feedback and the photo.

IC2 has correct orientation.

0.709V on PIN 4.

Is there anything else I need to check?

Mean while I will check solder joints and tidy up.


#6

This voltage should be found on pin 4 of IC2 too.
Please check the connection between point F and pin 4 of IC2.

charge10

charge13


#7

point F is now 0.709V, when I measure at point F with ground of multimeter on the negative point where two oscillicope leads are.
If I measure over the zener diode I see 0.709V


#8

5.12V over zener when power is on.
Now I have -5.12V at point F.


#9

I now have -5.2V at IC2 pin 4. I have not changed anything so confused.


#10

Hi

One other point is that I am using a USB 3 connection.

Does this influence the board?

At present I have all the correct voltages at points A through to F and at IC2 pin 4.

Calibration results:

CH1 offset at 2V/div : 179 FAIL
Rounds : 51
CH1 offset at 1V/div : 56 FAIL
Rounds : 51
CH1 Y-position low, CH1_DAC1 0 83
Rounds : 51
CH1 Y-position mid, CH1_DAC0 0 179
Rounds : 51
CH1 Y-position high, CH1_DAC2 0 255
Rounds : 32


#11

The USB cable can be connected to USB 3 socket of the PC without any problem.
There may be some bad soldering on the board or solder bridge …


#12

Well bad soldering is sure a possibility.-)


#13

Please check IC1 orientation.


#14

Notch is facing the capacitor bank.


#15

Calibration results:

CH1 offset at 2V/div : 77 FAIL
Rounds : 51
CH1 offset at 1V/div : -46 OK
Rounds : 51
CH1 Y-position low, CH1_DAC1 255 0
Rounds : 33
CH1 Y-position mid, CH1_DAC0 255 77
Rounds : 51
CH1 Y-position high, CH1_DAC2 255 173
Rounds : 51


#16

This result may indicate that there is no +5V on pin 8 of IC2.

IC1 orientation seems to be OK.


#17

+5.027V is on PIN 8 of IC2


#18

alibration results:

CH1 offset at 2V/div : 77 FAIL
Rounds : 51
CH1 offset at 1V/div : -46 OK
Rounds : 51
CH1 Y-position low, CH1_DAC1 255 0
Rounds : 33
CH1 Y-position mid, CH1_DAC0 255 77
Rounds : 51
CH1 Y-position high, CH1_DAC2 255 173
Rounds : 51


#19

OK - Please check the voltage on pin 1 of IC2.
There should be about 1.6V.


#20

Here are the voltages measured on all IC2 pins:
1: 1.56V
2: 0V
3: 0V
4: -5.2V
5: 0V
6: 0V
7: -1.65V
8: 5.0V

The voltages are measured when the USB cable is connected but the PC software EDU09 is not running.

On IC1 pins the voltages should be:
1: 0V
2: 0V
3: 0V
4: 0V
5: 0V
6: 0V
7: -5.2V
8: 0V
9: 3.3V
10: 0V
11: 0V
12: 0V
13: 0V
14: 0V
15: 0V
16: 5V