Can't get K8203 to run on Ramps 1.4


#1

Hello,

i’am using the K8200 for a few years now. Unfortunatly the USB connection broke last year. I installed an Arduino with Ramps 1.4 board and everything worked fine again.
Now i want to upgrade my printer to dualextruder. I bought 2 x K8203 extension kits but can’t get it to work.
My problem is… that the new stepper motors don’t want to move. If i try them with the old driverchips the motors run but with jitter movements. If i connect the old steppermotor everythin works fine.
With the new steppermotors and the Highpower driverchip nothing happens (and the Arduino board get realy hot…but not burned yet because the old confuguration still works if i rebuild that).
I tryed to install the new firmware (downloadet at the vellerman website) but it seems to be to old because i get an errormessage (fpos-t…). I used the Version 2.2 because i don’t have the Z-axis upgrade. When i search for that i find the information that i use an too old Marlin.ino!?!
I searched a lot now but can find the propper settings. Shure i tryed alot by using different settings at the “movement settings” part of the config.h.
So i run out of ideas now…is there anybody who can help???

Thanks in advance
RoHa65
(soory if my english is not perfect at some points :wink: