Cant setup k8400 with 1 print head


#1

I cant get the printer to accept the new firmware. I have installed the USB drivers, the printer is only connected to the pc via USB. I have downloaded the firmware for one print head and extracted it, also installed Arduino software. The COM port is correct (tested by unplugging the printer) and the board is set to "Arduino/Genuino Mega or Mega 2560.

The blue pin is connected to the JPROG pin connecter.

When uploading the firmware it stops at:

#define CONTROLLERFAN_PIN 2 //Pin used for the fan to cool controller (-1 to disable)

with the following error message:


Arduino: 1.8.6 (Windows 8.1), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from sketch\Marlin.h:21:0,

             from sketch\Marlin_main.cpp:30:

Configuration_adv.h:64:29: error: pasting “/Pin used for the fan to cool controller (-1 to disable)/” and “_DDR” does not give a valid preprocessing token

#define CONTROLLERFAN_PIN 2 //Pin used for the fan to cool controller (-1 to disable)

                         ^

sketch\fastio.h:53:37: note: in definition of macro ‘_SET_OUTPUT’

#define _SET_OUTPUT(IO) do {DIO ## IO ## _DDR |= MASK(DIO ## IO ## _PIN); } while (0)

                                 ^

sketch\Marlin_main.cpp:533:5: note: in expansion of macro ‘SET_OUTPUT’

 SET_OUTPUT(CONTROLLERFAN_PIN); //Set pin used for driver cooling fan

 ^

sketch\Marlin_main.cpp:533:16: note: in expansion of macro ‘CONTROLLERFAN_PIN’

 SET_OUTPUT(CONTROLLERFAN_PIN); //Set pin used for driver cooling fan

            ^

Configuration_adv.h:64:29: error: pasting “/Pin used for the fan to cool controller (-1 to disable)/” and “_PIN” does not give a valid preprocessing token

#define CONTROLLERFAN_PIN 2 //Pin used for the fan to cool controller (-1 to disable)

                         ^

sketch\fastio.h:53:64: note: in definition of macro ‘_SET_OUTPUT’

#define _SET_OUTPUT(IO) do {DIO ## IO ## _DDR |= MASK(DIO ## IO ## _PIN); } while (0)

                                                            ^

sketch\Marlin_main.cpp:533:5: note: in expansion of macro ‘SET_OUTPUT’

 SET_OUTPUT(CONTROLLERFAN_PIN); //Set pin used for driver cooling fan

 ^

sketch\Marlin_main.cpp:533:16: note: in expansion of macro ‘CONTROLLERFAN_PIN’

 SET_OUTPUT(CONTROLLERFAN_PIN); //Set pin used for driver cooling fan

            ^

exit status 1
pasting “/Pin used for the fan to cool controller (-1 to disable)/” and “_DDR” does not give a valid preprocessing token

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.


How do I fix this?


#2

Solved: Wrong version of Arduino. For some reason the latest version doesnt work. Use 1.0.6!


#3

It’s a memory issue (amount is too small to use the latest versions).