Connecting USB Cable to motherboard K8600

Hello - I have built the K8600 and most went smoothly - however the USB connector [type B] is mounted perpendicular on the motherboard.
If one wants to connect a USB cable - bending the cable will not be possible as there is not enough distance to do so and this part of the cable is also too rigid.
I hope I missed something … and Velleman has not overlooked a design issue forcing the user to leave the bottom plate open - even then the cable will obstruct. Also the related chapter 6 [Using the printer] is not filled in … - so a photo is not available to clarify this issue connecting the USB cable with the printer … It is a pitty that the USB connector is not accessible from the outside …

Thanks for all technical feedback !

Gazelle

Hello

This is chosen on purpose.
The USB is only there for updating the firmware.
As stated in the specifications( communication: an SD card for direct printing and a USB connection for updates )
It’s placed in such way you can’t use it while printing.

Best Regards
VEL337

I wonder why the Nano is made so that one can’t print through the USB? In Vertex it works very well and is much more practical than fiddling with the S-cards.
Also, why did the Repetier Host for Nano install something like Repetier Server? The Nano dosn’t seem to have Network connection either.

The repetier server is something from repetier their self. You can perfectly uninstall the server you don’t need it.

You can buy a 90degree usb-90 degree angle connector and then let the usb-cable go through the same hole in the back as the cables for the hotend.

Today I have printed from an raspberry pi using good old pronterface with no problems. Prints both from a file loaded into pronterface and from the sd-card in the nano.

Next is to use octoprint as host and simplify3d as slicer. (one slicer and one interface for all my (3) printers)

Have fun
/Niels

Did you have any luck to connect the octoprint?

Haven’t tried to print from USB yet, but I am able to move axis around from Cura (so octoprint will probably works fine)

Have anyone tried to sett up a raspberry pi with reptire server on and connect it to the motherboard?

Hi Niels,

Did you use the USB port to run the Nano from Pronterface?!

If, then it wouldn’t be impossible to run Octoprint (Octopi) with it, or?
Has anyone tried it with success?

/Charles

One answer to my own question to help you folks coming here to search for some wisdom is that YES! You CAN use the USB port inside the Nano!
You buy a 90 degree usb cable and download Repetier Host at http://www.velleman.eu/downloads/files/vertex-nano/software/vertex-nano-3d-printer-repetier-host-1-6-2.zip and install it.
Plug it in, click “Connect” in the upper left corner and if all goes to plan you and your Nano is shaking hands.
Very convenient and sooooo much easier than to run back and forth width a SD-card!
Load a .STL file, slice it, and send it to the Vertex Nano via usb. Done.

Now… it seems to work with the small demo file “Vertex logo keychain” but it might be problems if you want high speed and many small details as I would guess there might occur some traffic jam with in the USB since OS like Windows tends to do stuff in the background making the dataflow lagg, but nothing I noticed so far though.

whether it is compatible with OctoPrint is yet to see but otherwise you might solve it using TeamViewer and a old computer and maybe a USB camera to get some remote safety.

One last thing, it could be worth the work to get Marlin 2.0 in the printer, it gives you some nice features. :slight_smile:

why not use the GPIO?