Device recognition needed to get out of Demo mode


#1

pcsgu250: Can’t get microphone on Ch2 recognized. My entries …
Oscilloscope>options>Hardware Setup>pcsgu250>OK>‘no hardware response’
Mic is a simple crystal mike with no internal power source. What kind of signal is needed on Ch2 for device recognition?


#2

Do you have the drivers loaded?
Check device manager.
If not you can download them from here
http://www.vellemanusa.com/support/downloads/?code=PCSGU250
If this is on some versions of Windows 8 or 10 you will need to disable the driver signatures.
Do this before loading the drivers.

  1. Windows Key + R
  2. Enter shutdown.exe /r /o /f /t 00 [color=#BF0000]<- These are Zeros Note the spaces[/color]
  3. Click the “OK” button
  4. System will restart to a “Choose an option” screen
  5. Select “Troubleshoot” from “Choose an option” screen
  6. Select “Advanced options” from “Troubleshoot” screen
  7. Select “Windows Startup Settings” from “Advanced options” screen
  8. Click “Restart” button
  9. System will restart to “Advanced Boot Options” screen
  10. Select “Disable Driver Signature Enforcement”
  11. Once the system starts, install the drivers

Sorry I can’t help with the mic.


#3

Thanks for quick reply.
I get into Demo mode OK, with no errors and test various settings. Does that not mean I’ve loaded drivers OK?
I’m using win 10 on a Dell pc. So I load win 2000 stuff. Is that suspicious?


#4

When you say win 2000 stuff do you mean PCLAB2000LT?
If so this is the software.
Demo mode is just that it runs on your computer with out the hardware.
The drivers need to be loaded to use the PCSGU250 with the software.
What do you see in device manager?


#5

1st. Grateful for concise, clear and insightful responses. Best Forum I’ve engaged.
2nd. Your deduction is correct. PCSGU250 driver was never installed. After a umber of tries it is now installed as pcsgkul250_winusbdvr2.zip[folder]am64, []i386, and file MCHPWinUSBD
So it looks like the zip file was properly opened and installed. However, the osilloscpe still doesn’t recogize any attached hardware on Ch2. Any more excellent suggestions?


#6

There is a calibration port on the back of the unit.
Try touching the tip of the probe to it.
You should get a square wave.
Next try testing a battery.
Is you get a square wave from the calibration but can’t read the voltage from the battery this may indicate that the ground on the probe might be defective.
If you can not get a reading from either then you might have a defective probe (test on channel 1) or channel 2 on the scope is defective.


#7

Deleted a few files and started over installing pcsgu250. This was successful. However, on running it I got a serious error.
“Access violation at address 004E8C8F in module ‘PcLab2000Lt.exe’. Read of address 00000047.”
I read that this involves protected memory. It’s a new one on me and I’m not clear on how to fix it.


#8

Hello,

For installing the driver in a correct way on Windows 10,
You can download a step by step guide at this link.

link: downloads.velleman.be/6beb175e2d … _10_GB.pdf

Attention: this link is temporarily one week available for download.

Normally after this, the software runs in normal mode and recognizes the attached hardware.

Regards Velleman Support


#9

Frustrated! Several tries and can’t get these 5 steps to work:

  1. Downloaded pcsdrive-win80.zip
  2. unzip to “Downloads folder”
  3. Connect PCSGU250 to USB port
  4. Reboot in “Driver enforcement mode” ( =“Disable Driver Signature Enforcement” ?)
    (Shift+Restart)>Troubleshoot>Advanced options>Startup settings>F7
  5. Control Panel>Device Manager>PCSGU250 Oscilloscope/Signal Generator
    update driver>browse>my pick
    !! Driver not found !!
    not found in … This PC/Downloads/pcsdriver-Win8
    PLease enter another location. The location specified does not exist or can’t be reached"

That is the location of the driver.
What am I doing wrong?
Thanks for any suggestions.


#10

Just wondering.
Did you download the latest version of PCLAB200LT from the website or did you load it from the CD.
The files on the CD are very old and do not work with Windows 7 8 or 10
Also did you unzip the drivers and software before trying to load them?


#11

Thanks for the attention.
Yes, I downloaded PCLAB200LT at least 3 times from the web.
Yes, drivers were unzipped before use.
Perhaps there’s a clue in these observations:

  1. PCSGU250 icon appears in Devices & Printers Win 10 list;
  2. PCSGU250 Oscilloscope/Function Generator is listed in Devices Manager Win 10;
  3. when clicked PcLab2000LT and within this program and then trying to switch from Demo to Hardware Settings, this error is thrown … “No hardware response!”
    Thanks for your help.

#12

Hello

Start the software as administrator.

Right click onto shortcut icon “PcLab2000LT” and choose run as administrator.

check now, if the hardware will be found in software.

Regards ,

Velleman Support


#13

Did steps then …
clicked PCSGU250 Oilloscope/Function Generator in Device Manager.
This produced “Access violation at address 004E8C8F in module ‘PcLab2000LT’ Read of address 00000047”
Clicked on that message and got a 2nd drop down window; Unable to assign “Alt + B” as hotkey.
Clicked and got into the program and again stopped at ‘No hardware response’.

Beginning to think it’s not my day!


#14

No success downloading PCSGU250 for lack of a program – UPDSPSPI.dll.
After a major system crash, then a complete cleaning of computer, I’m now restarting attempts to load PCSGU250. PC-Lab 2000LT downloaded OK. But I have no luck with PCSGU250. First I disengage the windows 10 dll-signature filter and download Pc-Lab 2000LT OK. Then I’m unable to download PCSGU250. I have searched for sources of UPSPASPI.dll and find fixes for malfunctioning programs but no sources for the original program. Apparently, it is not an original dll delivered with windows 10. Any recomendations of where to get it?
Thanks for ideas. edchraig


#15

Dilemma! Running PCSGU250 on Windows 10 is hopeless. It cannot
be run on my hp-15 laptop for lack of a Microsoft signed driver that is suposed to be issued
with WIndows 10, UPDSPaPI.DLL. (Its function is to prevent memory conflicts.)
All my web searches, plus phone call with Microsoft support, for a download source failed.
They, and MS, say to uninstall the driver and reinstall it one or more times until it works. Of
course, this assumes you have the driver already in place, which is not my case. A Microsoft
Support agent redirected my call to a ‘network-protection expert’ (unidentified company).
He immediately pressed for purchase of his service to clean my computer of viruses, trojans,
and other issues, plus installing any missings drivers ($499.99 of protection for 5 years!).
However, he would not guarantee he could include a particular driver. My local computer dealer/fixer searched a new, on-the-shelf PC with windows 10 installed and did not find this ‘supposed-to-be-preinstalled’ driver. That’s my dilemma! After purchasing computer cleanup, virus and trojan removal, and installation of missing drivers (which ones cannot be predetermined), and failure to find the
driver on a new PC, prospects of ever running the oscilloscope seem to be nil.
Does the Velleman oscilloscope actually run on windows 10? If so, is there a known source for the
driver?
Thanks for any ideas.


#16

“If this is on some versions of Windows 8 or 10 you will need to disable the driver signatures.
Do this before loading the drivers.”

Hello. I’ve just spent several hours to try in vain to make my PCSGU2000 to be recognised by my the PClab2000.

I have tried: the disabling of the signature enforcement is just not allowed on my PC (HP-Compaq) with Windows 10, and this is coherent with the security politics which was annouced by MS.

The fact is that it is supposed to be you the seller, to have the certificate updated at disposable, and not the consumer to spend hours to try procedures which would disable security modes it if was even today allowed.

So, now, what do I do now with a product I just can use since 2 years I have change my computer and been able to use only 1 time? :frowning:

Your device and software looks great but until now, it was just like if I took a note of 100 € and burn it :confused: I can tell You it doesn’t encourage me to do any other purchase from your mark and I won’t unless I can use the device I have paid for.

Nevertheless, I know the problem the problem comes that MS oblige you to pay for any security certificate but if we had to ask you to pay for the time all your users, including me, we spend in vain to try to make your device working on our computers, I guess You could pay it and having it at disposal for your users, or send a device which works with Windows 10.

PS: I did this procedure too without success “Start the software as administrator. Right click onto shortcut icon “PcLab2000LT” and choose run as administrator.”