Extruder troubles: Filament feeder keeps jumping back


#1

Hi,
I got myself a Vertex Delta K8800 a few weeks ago, and after assembling and calibrating the printer it worked just fine. But after some prints that came out like expected, I encountered issues with the bowden extruder. It works just fine for a while and then suddenly starts pulling back the filament randomly, which results in a poor printing due to a lack of material. When doing so, it does not sound and look like “normal” stepper motor operation. It’s more like the motor is jumping backwards about eight or ten degrees, pulling back the filament. This produces a loud and harsh noise. This repeats a few times, then the extruder returns to normal operation for a while until it all starts over again.
I examined the stepper motor which seems to be flawless. I also eyeballed the controller PCB, which also seems to be fine. Same applies to cables, connectors and solder joints. Finally, I checked the extruder motor’s trimmer alignment as described in another thread. I measured the voltage which is supposed to be 1,05V, and it’s spot on.

I urgently need the otherwise great printer to work again, so I appreciate every assistance. Thanks!

Greetings from Germany
Martin


#2

Martin,

Have you tried to print the first projects again using the same gcode?
Just trying to figure out if this is a printer problem or a slicer issue.


#3

Hi,
thanks for your answer. The slicer (corrupt gcode, that is) was my first suspect. So I reprinted a known good project using gcode that was still on my SD card. This time, it failed.
I also tried to figure out wether or not the motor was exhibiting any temperature sensitivity. But heating it up to it’s temp limits didn’t make it fail more (or less) often.


#4

This is huge guess but maybe something to test.
https://manuals.velleman.eu/article.php?id=783


#5

It would have been great if that was the cause. So easy to fix. But unfortunately, it isn’t. The printer does not try to unload the filament. Also, the LED attached to the filament detection does not light up at any time.
It’s a sudden movement in reverse direction. It’s definitely not normal motor operation. My guess is that the motor misses some of the electrical pulses. But I can’t figure out who’s the culprit. It could be the motor, the cable, the connectors or the motor driver on the main PCB.

Seems to be complicated. Maybe a Velleman technician has an idea. That’s what I’m hoping for now…


#6

Unfortunately I’m out of ideas.
Could you post a video of it?
That might help a little.


#7

You could also open a trouble ticket in this link.
https://support.velleman.eu/


#8

I’m going to try to catch it on video. It’s an intermittent failure. Considering Murphy’s law, what are the odds to succeed? :wink:
I’ll wait until tomorrow, maybe a Velleman technician replies by then. Maybe I have to open a ticket.

Thank you very much for your help.


#9

One last thought.
Check the cable that plugs into the motor.
Maybe it’s not seated all of the way.
Maybe unplug it and re-plug it


#10

Hi Maddin,

This was a problem with some of the printers of the very first batch production run. It could be you have one of these printers. We have identified this problem and fixed it going forward. The fix for this is giving the stepper motor a little extra current. This can be done by adjusting a trimmer next to the stepper driver on the main board of the printer. for this however you will need to get to the bottom of the mainboard (dissasemble some parts) and know how to use a multimeter.

If you are keen on trying it yourself I can send you a guide on how to do this. If however you are not interested on doing this yourself you can create a ticket here: https://support.velleman.eu/ 1 and note the problem and also add that a Velleman technician has told you that “a change in extruder stepper driver current” is needed. You will need to send your mainboard or printer to us so we can make the correction.

If this is not the problem, it can also be you have a partially clogged printhead or the plastic parts on the extruder block are not mounted correctly. Both are easy to check by dissasembling these parts and checking them.

Sincerely


#11

VEL327,

as I wrote in my initial post, I already disassemled the printer, popped out the mainboard and measured the voltage as described here: https://imgur.com/a/8zi6YGy
It’s exactly 1,05V. So the motor current should be correct, right?
I also disassembled the extruder’s cold end, checked it and put it together again. It was (and is) flawless.
The printer’s nozzle is not clogged, I checked that as well.

Please send me the guide you mentioned, I think I can fix it myself then - provided it’s really a matter of adjustment and not about a faulty part.

Thank you.

[edit: typo]