Feeder issue on K8800


Enthousiastically I finally got my bed level issues solved (see other track in this forum) when all of a sudden my feeder is not working anymore. Worked the day before and now nothing anymore. It looks like the stepper of the feeder is working but there is absolutely no grip anymore on the PLA Vertex filament.
I uninstalled the feeder (The bolt that has to be loose is loose, again, it worked perfectly in other prints) and verified everything but I not find the issue. Also I checked. All looking good as far as I can see.

If I push gently on the filament, the filament is being loaded. When I leave it as it should be, it’s not feeding.
Hereby a video;

It looks like the feeder is not having the grip anymore and the piece is broken.
What now? Warranty and a new piece? Any suggestions?

Kind regards,


Issue found!
M3 bolt around the stepper axis was not tightened anymore. So the axis was rotating being lose from the gripping wheel.

1 Like


Indeed. Nice to hear the problem is solved.

I see in the video that the motor shaft rotates faster than the pulley.
This means that the set screw has come loose. Or it was not fixed enough.

@ others:

To solve the problem, disassemble the extruder, you can consult this document: Extruder assembly instructions => https://velleman.bitrix24.eu/~dtWqK
Fix the set screw, normally the problem should be solved.

Velleman support