Heating fails when print is paused

I’ve been trying to do a two colour print by pausing the printer and changing filament. First attempt I watched the print and used the printer control menu to pause it. I unloaded the filament and tried to load a different colour but after I selected the load filament option, after a pause the printer displayed Heating Failed, Please Cycle Power. After switching off I couldn’t resume so that was wasted filament.

Second attempt I told Cura to pause the print halfway. This time it I got Heating Failed when I tried to unload the filament.

So far I haven’t had this problem when loading or unloading filament with no print in progress, but with the printer paused it’s failed every time. Has anyone else had this problem? Any ideas what might cause it?

P.S. Why do we have to cycle the power if heating fails? Can’t the printer cycle power to the heater and keep everything else including progress on the current print? The current method can lead to wasted time and filament.