HPS50 driver file empty when trying to make a Capture


#1

Hi,

The program connects Ok to my COM4 port but when I try to make a Capture I come to a Driver file that is empty and can not make a Capture. Instrument was bought at Conrad September 15 , 2015. I use Windows 10 operating system.HP EliteBook 2170p.
Please send me the driver file.

Best regards
Johan
Phone: +46 707 398 229


#2

The HPS50 has not yet been tested under Windows 10, so we do not know how it will behave


#3

Hi,

Please then send me the Windows 7 or 8 drivers. These should work in W10 also. I probably can run the computer in compatibility mode for these. The problem seems to that your download of 3.3 version does not contain the driver. I only get two small files, HPS50.cat 8kB and HPS50.info 4kB at installation. Are these the drivers?

Best regards
Johan


#4

Hi again,

Actually the capture work. The problem is that HPS50 does not send any data. I can connect to the right COM port and save the grid screen without any data. Should I return it to you or Conrad for repair? Have tried to run in compatibility Mode W98, XP, Vista, W8 nothing helps.

Best regards
Johan


#5

Have you tried it on a different machine?
Maybe Windows 7?
If you don’t have one maybe a friends machine?


#6

Hi,

Will ask one of my brothers to test with XP and W7 computers when I meet him next month.
HPS50 is a fantastic instrument and it is a pity that W10 isn’t supported yet.
Velleman may need to address this because more and more people are moving to W10.

Best regards
Johan


#7

I’m sorry, this is very confusing…

So you don’t need the driver, because you have a com port and can connect to it?
You can make and save a screen capture?
But the problem is that you don’t see any measurements?

Did you put the HPS50 into binary send mode? (page 26-27 of the manual)
velleman.eu/downloads/0/user … _hps50.pdf


#8

Yes the COM port connection works Ok.’ If I change USB port it changes the COM port number correctly.
I can capture and save the oscilloscope grid= Ok.

I can not get any X Y values or oscilloscope graph. It seems like no testdata is sent.

Yes the Binary mode is set. All settings are according to the instructions.


#9

Then most likely it is indeed due to Windows 10. A lot of devices that use a virtual COM port have trouble on Windows 10. We will test it to confirm.


#10

Ok, many thanks!


#11

Is it possible to use an USB Bluetooth transmitter to bypass the W10 compatibility problem? Found this article on the web:
handheldsci.com/kb

Is the mini USB on HPS50 powered from the HPS50? If soo I could use a very cheap USB Bluetooth adapter by using an interface cable and wireless connect with my computer.


#12

Found this on the web: driverscape.com/download/usb … port-(com3

Do not know if it is scam or safe. Do you know? If safe it seems to create a virtual COM port in W10.


#13

[quote=“akerblad”]Found this on the web: driverscape.com/download/usb … port-(com3

Do not know if it is scam or safe. Do you know? If safe it seems to create a virtual COM port in W10.[/quote]I would absolutely not download any driver from these websites.


#14

Ok, acknowledged, thanks!


#15

I’ve tested and it seems that both, the HPS50 v3.3 and HPS40 v1.0 software work ok under Windows 10. However the HPS50 software seems to ignore screen captures done by holding Memory button on the scope (yet, I’m using the HPS40 scope). Realtime graphing works fine in both software versions. For HPS40 software, the scope must have assigned a COM port in range 1 to 8 (you can change the port number assignation from the Device Manager), but in my opinion it looks and works better than the HPS50 software.

HPS50 software looks for a specific description behind the COM port, if it doesn’t find it, it will not list it in the combobox, however you can still type-in port name (i.e. COM2) and it will work, the check is done solely on listing the ports and not on connecting the device.


#16

Under Windows 10 the Velleman HPS50 is seen as USB Serial Device (COM3). Data from the connected HPS50 is not recognized by the HPS50 version 3.3 software. I can, however, connect to it with a terminal program and see that data is actually being sent.

Attempting to install the HPS50 driver included with the software manually results in the following error:

Is there a fix for this yet? If there is not a fix already available or coming very soon, I’ll have to return the scope to my vendor.


#17

You will need to manually install the drivers.
Go to device manager and find the HPS50 right click on it then left click on update drivers.
in the prompts navigate to c:\Program Files (X86)\Velleman\HPS50\Drivers


#18

As I said previously, I already tried manually installing the driver.

I even tried bypassing the check for driver signing last night. If I do that, I can force the driver to install, but the HPS50 application still fails to get the data from it. I can connect to the manually installed driver with a standard terminal program and successfully receive data but that doesn’t help me with captures.


#19

I also tried running the HPS50 program as an Administrator but the result was no different with either driver. (I tried both.)