Install E3D extruder

Install E3D extruder:

Marlin Firmware decrease power, the E3D extruder is 12V K8200 15V

//#define PID_MAX 255 // limits current to nozzle; 255=full current
#define PID_MAX 150 // limits current to nozzle; 255=full current

Upload firmware to your k8200

Repetier host

Get PID settings for E3D extruder

Go to Manual control

  1. Key in M303 S230 C5 in G-Code then presses Send.
    M303 is PID auto calibrate
    S230 is setting the temperature to 230C
    C5 is after reaching temperature 230, do 5 cycles up and down the temperature.

You can see from the log, the PID Autotune starting

  1. You will get results from the log as below.
    P: 11.07
    I: 0.74
    D:41.19

  2. Go to Firmware eeprom config
    Put PID values in the PID settings:
    Press Save to EEPROM.

Wow, auto PID tuning, thats awesome. Thanks for the tip, have to try this asap.

BTW, another tip; the velleman stock heating element fits just fine in the E3D. In fact, it fits better than the E3D one, which in my case was really loose and needed a lot of alu foil. That said, even if using the stock heater, then Im sure its a good idea to tune those PIDs, because the E3D uses a much smaller heatblock.

My element fits well, only the temperature sensor mounting of the E3D is bad…

Hi wallie,

please keep in mind that this is about the E3D hotend, not extruder. Since we all don’t know what the future will bring (maybe some day an actual extruder of that name?), it’s best to keep things clear.

Your settings reduce the max current in PID mode to an average of ca. 2.5 A, which will result in 37 W of heating power, or 7 W more than the stock heater cartridge. This should work without problems, but it’s necessary to note, that during the time when the cartridge is actually on (the current reduction uses PWM), it’ll draw its full current from the power supply: 4.2 A. The stock heatbed uses about 2.5 A, so if this is combined with the E3D, the power supply is near or over it’s maximum rating, even without counting in the motors.

Additionally, when the hotend heater is started, it’s not driven by the PID, but in bang-bang mode. The max current in this mode (#define BANG_MAX) should be reduced similarly to the PID value. This will reduce overshoot and also the load on the power supply. If the heater cartridge is driven by a potent power supply and full current can be used, it may be beneficial to increase the PID_FUNCTIONAL_RANGE to combine fast heat-up time and low overshoot.

Cheers,
kuraasu

Hi kuraasu,

Thanks for the info, on this moment i use to separate meanwell power supply’s 24v for the heating bed and 15 V for the rest both 100w.
So in my case, I think this will no problem…

This are my PID values
P: 11.07
I: 0.74
D:41.19

Cheers
Wallie

That worked a treat. Before auto tuning (or manually changing the PIDs as I planned), I got wide over and undershoots, easily 5C above and below the target. After tuning, its not deviating more than ~1C, and typically <0.5C. Quite impressive. Well, except for the initial warmup, then it will blast past the set target by almost 10C, then drop twice that amount before stabilizing, but thats not really a problem.

Thanks again for the tip!

I can’t seem to fill out any values for PID, when i open the eeprom settings everthing is on 0 and the pid line is greyed out.

Also, when i do the PID autotuning it starts, keeps going for a while, and then i get this error:

PID autotune failed! timeout
Error: Line Number is not Last Line Number+1, Last Line:129

[quote=“Jelath.O”]I can’t seem to fill out any values for PID, when i open the eeprom settings everthing is on 0 and the pid line is greyed out.

Also, when i do the PID autotuning it starts, keeps going for a while, and then i get this error:

PID autotune failed! timeout
Error: Line Number is not Last Line Number+1, Last Line:129[/quote]

Anyone had the same problem?