Installing the printer on a MAC

Hi - Can you kindly update us in how to install the printer with a MAC.
Using: OSX 10.8.4
Unable to communicate with the printer…
Driver is downloaded: FTDIUSBSerialDriver 10_4 …


Hi guys…
For any of you having same problems…
Start Repetier and select under Port: “Virtual Printer” communication should work…


We will update the manual asap with instructions how to connect the printer with a mac.

Hi - since nothing was published - I just needed to play around a bit until getting the
correct settings running.
Repetier Software looks also different on the mac.
Its manageable…

Is there any information about working with a Mac?

Works on the mac…
I am using a simple MacBookAir to connect with the printer.
I was only able to test motors, stoppers, fan and extruder. Because of a faulty control board I was unable to
continue because the bed heater on the board is INOP.
Printing unable to test, waiting for a new board to arrive.

Rather then that works fine on the mac…

I think printing will not be the problem once you have communication to the printer.
Repetier software on the mac looks a bit different but manageable…


i have the same problem under 10.8.4

Hi Zaupelmann,
what problem are you facing? Bed Heater INOP?

I have installed the drivers from ftdichip and the Repetier Software! But the Computer shows only a virtual printer!
When i use this it will not Work!

i don’t no maybe is the Card from the Printer defect


the connection and control works for me with the 64Bit FTDIUSBSerialDriver 10_7 under osx 10.8.


Try under Printer -> Printer Setting
PORT: Select: usbserial-AM021X7T

Should work now…


I have a Vellman 38200 and is OSX10.8.4 on my mac, I’ve got to find the problem the card from the 8200th
've tried everything, I need a good description.
I would be glad if someone can help me.

Sorry K8200 Vellman

Hallo zaupelmann,

ich habe zu eigenen zwecken eine Kurzinstallation für OSX 10.8.4 erstellt.
Ggf. hilft es ja weiter.

Läuft bei mir auf MacBook Pro und MacMini.

Hello zaupelmann,

i created a short manual for intalling under OSX 10.8.4 for myself.
Maybe it helps.


Hallo David

Erst einmal möchte ich dir für deine mühe danken.
Ich kann nur sagen das dieses Bord Große schieße ist so etwas müsste verboten werden ohne passierende Software verkauft zu werden.
Ich habe alles neu aufgespielt und bin genau nach der Anleitung die du mir geschickt hast gegangen aber immer noch der gleiche misst.
Ich weis echt nicht mehr weiter.

Mit freundlichen Grüßen
Hello David

First of all I want to thank you for your effort.
I can only say that this board is so great shoot something should be forbidden to be sold without passing software.
I’ve been playing all new and went exactly according to the instructions you sent me but still the same measures.
I am really looking any further.

Sincerely yours

Hello Walter,

does the ctrl. board start to blink when Connecting to the Mac?
Try to press the reset butten.
Of possible try to test with windows.
Maybe the Board doesn’t work properly.

Silly question, but have you got the main power on?
I selected the funny port name on my Air and the USB power was enough to light the leds but it didn’t start responding until I actually powered the mains adapter on…

Hello Dear Velleman Support Team,

I received the new board and we have the same problem without a new result.
I guess the connectivity or the configuration you provide do not match.
Somehow Heater 2 will not work and the light on the control board will not light up.
I repeat if I switch the wires to Heater 1 ( Extruder ) the bed starts to warm up.

What is the next step now?
Waiting for your soonest reply.

Kind regards,

Hi - yes there was something wrong with the wires.
The cable was tree was broken at one single spot ( red cable ) the broken spot was in a very difficult
space to reach and to see.

I changed the entire cable tree.
Kindly send me the invoice for the new control board.


Works on a simple MacBook Air :slight_smile:
3D Art work is done on another Mac… … n=33936250

Thanks for the support…