K8048 Reprogram Mystery


#1

Hi.I have a Pic16F883 using MPLAB,picprog2009 and k8048. until now all has been well.I solder the 5 wires for ICSP and stick them using pins into the 8pin female receptacle.I have tried 8 new Pics same ones and all have error Pic not recognised.If I then put my first pic back in it will load ok. The only difference is the working Pic is actually in a circuit and the other 8 just have the 5 wires attached which has worked fine as a quick test in the past.
I am completely baffled and frustrated.I can’t remember what I did last time this happened,I wish I wrote it down.I think I reinstalled everything.I am using MCLR as I/O and INTOSC which I have read can have issues.
Ok here’s the interesting bit.In wizard in MPLAB when selecting templates from a library to build the project inc the ASM file template the ASM file when opened in editor should produce a template with a lot of the settings you require for this Pic Project.What comes up is the program I wrote for the Pic that works,so it has somehow been saved back to where the original template came from.This could have happened with the other templates which I am sure could affect the way picprog2009 communicates with the K8048 or MPLAB.So now basically put the K8048,picprog2009 or MPLAB will only recognise the first Pic I successfully programmed and the 5 wire test method has always worked before.Any ideas before I go insane.
Update: I restored my computer and reinstalled MPLAB and picprog2009.I checked the templates I was using to be sure they had not been corrupted and they were ok.Used wizard to build project.I was able to program a new Pic once and then it went back to not recognised.My 1st Pic will still program.