K8055 Programming interface wrapper (or library) for Java


#1

We have the latest USB Interface Card K8055N / VM110N DLL version (4.0.0.0) and have downloaded the latest “Complete SDK Pack (Rev 4.0)” for Windows 7, 64Bit. Unfortunately we cannot find any programming examples how to interface program this board using Java.

For a project we need to use the K8055N USB interface card to be controlled under Windows 7, 64 Bit using Java programming language.

  1. Can you please provide us with a small programming example on how to use and control the VM110N or K8055N using Java programming language?
  2. Can you provide a wrapper for Java?

#2

Hi,

We’ve investigated the possibilities with java.

And currently there is no native solution for java are available.

But it’s possible to call methods from a DLL with java. see here =>link
As an Alternative you could use a library written in java that can be found on GitHub (search K8055 in github).

In the mean time we will be looking into making a official java library and examples for the K8055N/VM110N.
(should be expected in coming weeks)

Best Regards,
VEL337


#3

Thanks for the Information.

Looking forward to the official native Vellemann solution for Win 7 / 64 Bit for Java supporting the K8055N/VM110N, comming soon.
We really need your solution (Java lib and examples) for a project latest until end of Jan 2016.

Best Regards
HWS


#4

Thanks to some nice work by VEL255, you can try the following Java package:
velleman.eu/downloads/files/ … N_Java.zip


#5

Thank you so much for providing the new DLL´s and Java interface and example code for the K8055N/VM110N!

We have used several functions of the new lib and its working great. :slight_smile:

Thank you and best Regards
HWS


#6

great to hear it’s working

Best Regards,
VEL337


#7

Hi!

You could try this too:
github.com/cranphin/libk8055_java

I could do with some feedback :slight_smile:

Cheers!


#8

Thank you for providing the K8055N_Java.zip.
I have unzipped it, read the PDF and opened the Java example program in Netbeans 8.2.
Running it in Netbeans, results in:
java.lang.UnsatisfiedLinkError: C:\Windows\System32\K8055NW_x64.dll: Can’t find dependent libraries

It seems to properly find and load K8055NW_x64.dll but then something goes wrong. As if another (depending) DLL is missing.
Clean and build the Java example, in Netbeans, works fine; no errors or warnings. But running fails.
(JRE=1.8.0_141-b15, Windows10)
Any help would be appriciated.


#9

Strange problem indeed…
You may try with this JDK version: jdk-8u191-windows-x64.exe available here


#10

Thank you for your swift reply.

I have downloaded that jdk1.8.0_191 and made it the new default platform for Netbeans, but the problem remains the same.

Also I tried java -jar “K8055N.jar” on the command line, outside Netbeans, with the two DLL-s in the same directory as K8055N.jar. This results in exactly the same error message (as above), suggesting it has properly found your K8055NW_x64.dll.


#11

OK.
It seems that maybe a dependent library is missing from your Windows.
One such is MSVCR110.dll.
The msvcr110.dll is a part of Microsoft Visual C++ Redistributable.
As a test I renamed MSVCR110.dll in the System32 folder and got following result when running the application in Netbeans:

java.lang.UnsatisfiedLinkError: C:\Windows\System32\K8055NW_x64.dll: Can't find dependent libraries
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857)
	at java.lang.Runtime.loadLibrary0(Runtime.java:870)
	at java.lang.System.loadLibrary(System.java:1122)
	at k8055n.K8055N.<clinit>(K8055N.java:61)
Exception in thread "main" C:\Users\VEL255\AppData\Local\NetBeans\Cache\8.2\executor-snippets\run.xml:53: Java returned: 1
BUILD FAILED (total time: 4 seconds)

#12

Thank you, that solved the problem!
Indeed this library file MSVCR110.DLL was missing from directory C:\Windows\System32, this was probably not a wild guess :smiley:
Fortunately I was able to copy this library from a similar PC, where it was not missing. The Java example program is now running properly and controlling the K8055N board.

I can further focus on using the K8055N from Java programs :+1:
Thanks VEL255


#13

No problem! I’m glad it’s working for you now!