K8062 64 byte mode instead of 8 byte

Hello,

I spent the last few months developing a C++ sound to light application as a university project. We are using the K8062 as our USB to DMX interface and we got it working fine on Windows/Linux/Mac by writing our own version of the code found in the Download section of the K8062. The USB library we are using is libusb. When we add only a few fixtures (up until ~8), everything is working quite smoothly, but the more fixtures we add the more laggy everything gets until at some point it is unusable. After quite some debugging and reading pretty much everything about the interface on the internet I think the problem comes down to the size of the USB packets we are sending to the K8062. Old K8062’s with an old micro controller and old firmware were only able to recieve 8 bytes per packet. The new ones should be ready to receive 64 bytes per packet (if I understood correctly).

The device we have was bought this year and seems to have the newest firmware (V3). When plugging it in the LED flashes three times and the micro controller is the PIC18F2550. With this everything should be set up for me to send packets of 64 bytes instead of just 8 bytes. But that did not work. When debugging the device with libusb it showed “wMaxPacketSize: 8” for both endpoints. There also only seems to be one possible configuration (“1”), so I could not activate 64 byte support by using e.g. libusb_set_configuration(device, 2).

Now my questions:

  1. Does the K8062 even support sending 64 bytes per packet?

  2. If yes: How do I enable my K8062 to be able to do so?

Many thanks in advance and best regards,
Johannes

I’m sorry, the firmware of the K8062 does not support 64 byte mode. Only 8 byte mode is possible.