K8200 Auto Home Fault


Please can someone help me with yet another problem with my K8200.

When using Repetier-Host and clicking on the Auto Home button, the bed travels all the way to the right and stops when activating the microswitch. The extruder then travels upwards by approximately 5mm


Here you have several homing buttons, separate for the X, Y axes (which raise the Z axis by x mm then set to the endstop position)
Z axis moves to endstop only and the main homing (green) which raises the Z axis by x mm then sets X and Y to 0 and then Z to 0.

In addition, there are also Gcode commands (but they are executed before or after printing)

But maybe someone knows how to change (or where) these parameters.
Regards Marcin

Hello Marcin,

I’m using v0.95F. These are the two buttons that I am using. I cannot lower the Z axis in order to engage with the microswitch. Whenever I click on either of these buttons, the extruder (Z axis gantry bar) moves up!

So if the Z axis works upside down you can change the firmware

in yellow(

If true enter false and if false enter true then it will reverse the direction of movement


Can I refer you to the problem on my other post on the K8200 and also a short movie clip which I have posted on my YouTube channel. If you search for Tom Gullan (I’m the guy with the dog on his lap).

This is what is happening when attempt to lower the bed in order to level it.

I cannot seem to be able to upload the firmware (see other post).


From what I see in the video this is not properly configured endstops.

And you can easily check it by pressing the end stop for the Z axis and turning on Z homing.
(set the arm in the middle to allow room for movement), releasing, pressing again and releasing then will stop the arm).

It should look like this, but let’s wait until you can upload the firmware.


The code on your screenshot looks different from the code in my configuration.h file.

As I don’t appear to be able to flash the motherboard, do you think this is a lost case?


You say that there are no errors.It is possible that there is something wrong with the motherboard.
And one more thing during firmware upload, Repieter, Cura must be turned off.
And until you upload the firmware, I can’t help much.
In the worst case, changing the motherboard to VK8200 / SP or ATMega or cheaper options.


After a lot of thinking and trawling of the internet, I now realise that after uploading the firmware to the motherboard, I MUST save the EEPROM… in all occasions I omitted this vital step…!! :frowning:

In the on-line manual, there is no mention of the VM8201 and having to RESTORE FAILSAFE then STORE MEMORY after an upload. To cut a very long story short, I am now able to change and upload the Arduino firmware but only whilst using Arduino

I have now uploaded the latest firmware (version 2) however, when I use Repetier-Host I have a problem:

  • The Z axis up and down buttons work fine
  • The X axis button works the opposite way round (travels in the opposite direction
    from the arrow
  • The Y axis button works the opposite way round (travels in the opposite direction
    from the arrow
  • The Z axis HOME button… bed stays stationary and the extruder gantry rises
    a few millimeters
  • The HOME button… moves the bed all the way to the right until the microswitch is
    activated, then the extruder gantry raises a few millimeters

At the moment I am unable to lower the extruder in order to level the bed.

I have not altered either the firmware or the settings on Repeteir-Host. Have you any idea what is happening and if so how to fix it?


So you have to reverse the axis X and Y

Set endstops as in the picture

Regards Marcin