K8203 Direct Drive Extruder Works Backwards


#1

Hi all,

I have just finished upgrading my K8200 printer with the K8203 extruder. I thought all was going well until the first print when I notices the extruder was working backwards. Manually extruding from Repetier causes the filament to retract and retracting causes the filament to extrude. I have confirmed the motor wiring is correct. Is there a setting I need to change in the software / firmware?

Also while I am asking… it said in the instructions when cutting the PTFE sleeve to ensure there was 70cm of tubing left but unless I have missed something it never mentions where this is needed.

Finally, does anyone know what the clearance between the extruder tip and hotbed should be when the Z axis is homed, I am guessing it will be less than the original extruder.

Thanks in advance :slight_smile:


#2

Hi, look for this line (or one simalar depending on the version of the firmware you are using) in configaration.h & change it from true to false or false to true depnding on its current setting (don’t take to much notice of the comment at the end of the line).

#define INVERT_E0_DIR true   // for direct drive extruder v9 set to true, for geared extruder set to false

Sorry can’t help with the rest of the questions.


#3
#define INVERT_E0_DIR true   // for direct drive extruder v9 set to true, for geared extruder set to false

That worked a treat Barnabybear thank you very much, extruder now working the correct way round… Time to print something :slight_smile:


#4

You need to load new firmware for it.
From this link
http://www.k8200.eu/support/downloads/

The one you need depends on what you have on the machine.
VM8201, K8204, K8203…


#5

[quote=“Wrong Way”]You need to load new firmware for it.
From this link
http://www.k8200.eu/support/downloads/

The one you need depends on what you have on the machine.
VM8201, K8204, K8203…[/quote]

Hi Wrong Way,

Thank you for your comment, I should have said in my original post that I have also upgraded the firmware (as per the instructions). I installed the Z-axis upgrade (K8204) at the same time and already have the LCD/SD module so downloaded and installed the following:-

[color=#0000FF]“FIRMWARE K8200 V2.3 - This version supports the K8203 DIRECT DRIVE EXTRUDER and the K8204 Z AXIS UPGRADE ROD AND COUPLER FOR K8200 and the VM8201 LCD and SD card controller. DO NOT FORGET TO RESET YOUR EEPROM SETTINGS AFTER THE UPGRADE! ©2011 C. Gubbels E. van der Zalm”[/color]

I also ensured to use Arduino software version 1.0.6 as I understand the newer version is does not correctly download to the Marlin PCB. It was then that I discovered the extruder working backwards.

The thought has since occurred that the instructions indicate you can fit the extruder as a LEFT or RIGHT direct drive extruder so depending on which one you pick the direction of the motor would be reversed? I installed it as a LEFT drive (as per the instructions) but if I have mounted it as a RIGHT drive the direction would have been correct.

By altering the line in the configuration.h file the extruder is now working correctly.

The next problem I have is that the “K8203-PLA-STANDARD.INI” wont load in slic3r (I am currently using 1.0.0RC3) the download says it is only compatible with version 0.9.10b so do I have to downgrade? that being said when you look at the file the header says “generated by Slic3r 1.1.7 on Tue Dec 23 19:35:56 2014” so do I have to upgrade?

Thanks.


#6

You could try 0.95F from the download page but you will need to make some adjustments in there.
I know the nozzle size will be one I don’t know about the rest.

The K8203 is not available in the USA yet.


#7

[quote=“Mrmike126”]Hi all,

I have just finished upgrading my K8200 printer with the K8203 extruder. I thought all was going well until the first print when I notices the extruder was working backwards. Manually extruding from Repetier causes the filament to retract and retracting causes the filament to extrude. I have confirmed the motor wiring is correct. Is there a setting I need to change in the software / firmware?

Also while I am asking… it said in the instructions when cutting the PTFE sleeve to ensure there was 70cm of tubing left but unless I have missed something it never mentions where this is needed.

Finally, does anyone know what the clearance between the extruder tip and hotbed should be when the Z axis is homed, I am guessing it will be less than the original extruder.

Thanks in advance :)[/quote]

I have exactly the same problem (stepper direction reversed) and questions (what about the mentioned 7cm PTFE? distance from the bed? calibration of the new stepper driver?).


REALLY VERY BAD DOCUMENTATION FROM VELLEMAN FOR THE K8203 KIT !!!

You need to search the documents on your own and the available pdf documents are not describing the replacement (old => new extruder) rather than complete new installation. And at the end you need to troubleshoot and ask around how to tweak the firmware to get it running. Sorry for this true words !!!


#8

FWIW, here is another option: I have inserted a four-pin connector between the motor wires and the rainbow cable. Naturally, the connector contacts are in the same order as on the ribbon cable, and the connector is reversible. By reversing the connector, I reverse the direction of rotation on the motor.

I’m ashamed to say, I smoke tested this first, before checking the motor schematic. It worked, and then I did my duty to check the schematic, and it confirms my strategy.

I’ll also mention, that I took care to wire my 4-pin heater/thermistor connection to be reversible: the two leads of each device are in mirror-image position. That way, my 4-pin heater/thermistor is unpolarized (works backwards and forwards).

I do appreciate the tip about changing the firmware parameter; I’m going to take advantage of that option as well.

I believe the reason that some of us experience the extruder running backwards, is that the extruder can be built either left-handed or right-handed, and the motor direction has to be changed when changing between the left-handed and right-handed configuration. My experience is that, following the instructions, I get the configuration that needs to have the motor direction reversed.

One of the latest comments laments the required attitude of discovery and adaptation that we bring to the K8200. I happen to like this kind of work. Anyone who desires complete documentation is surely disappointed. I do recall cutting through a piece of tape on the box that warns us: Not for Beginners. They are not kidding around there!


#9

I installed my K8203 last night.

I haven’t updated the firmware, as I already changed the motor direction when I switched from a geared 3mm extruder to a belt-driven design. Aside from direction of travel, are the any other code changes that warrant losing all of my work in reverting to a stock marlin build?

What steps/mm do you show for the E motor in the EEPROM settings? I’ve read values from 150 steps/mm for 1/32, and 75 steps/mm for 1/16.

A note about height: I had to bring the Z-arm down another 6.4mm on the rail to get the nozzle within the range of my home adjustment, has anyone else had to do this?

I wound up using 2 and 4 circuit MOLEX connectors on the hotend, thermistor, fan(s), and extruder motor cables so that I can revert back to the stock 3mm extruder. The installation looks really clean! Also, I ran another 2 wires for 12VDC supplied to a continuous hotend isolator fan to run all of the time. So now I have 2 fans on the extruder assembly; one for the isolator, and one for prints controlled by software.


#10

Yes, I just did that ~20 minutes ago. I was coming here to see if others had to do the same, since I didn’t see that noted in any instructions.


#11

Why is the line I should change, not visible here?


#12

Velleman have recently migrated their forum to new software, and it seems that some of the old formatting no longer works.

If you built the 8203 in it’s default handedness, you need to reverse the motor direction. The line you want to look for is in Configuration.h. Search for “INVERT_E0_DIR” and change the “false” on that line to a “true”, or vice-versa. In my copy of the firmware the line looks like this:

#define INVERT_E0_DIR true // for direct drive extruder v9 set to true, for geared extruder set to false

I hope this helps!


#13

where can i put these line in which program


#14

Open it up in the Arduino IDE 1.0.6
You will find it in the Configuration.h tab


#15

thanks must i reload it than i am not so technical in programming


#16

You can find the instructions here
http://www.k8200.eu/manual/printing/?c=007
Make sure you use Arduino 1.0.6 or lower.