K8203 too much extrusion


#1

Hello,

I have upgraded my K8200 with the 0.35MM DIRECT DRIVE EXTRUDER. After the upgrade there was far too much extrusion. I have to reduce the extrusion rate by 75 percent to get acceptable prints! Does anyone know what could be the reason for that?

What I have done:

  • download FIRMWARE K8200 V2.2
  • modified configaration.h (#define INVERT_E0_DIR false) to change extruder direction
  • flashed the firmware
  • reload EEPROM setting by sending M502 and M500
  • download K8203-PLA-STANDARD.INI
  • checked filament diameter 1.75mm (setting and measured my filament)
  • checked nozzle setting 0.35mm

Because I did not get good results (too much extrusion) using Slic3r I tried cura. It was the same result. So, I reduced flow rate step b y step. With reducing the flow rate by 75 percent I get acceptable prints. But this is not the way it should work. Has anybody an idea what could be wrong?

Greetings
tho


#2

Did you download the firmware and ini file from this page?
https://www.vellemanusa.com/support/downloads/?code=K8203


#3

Hi Wrong_Way,

Thank’s for your reply. I downloaded from:
http://www.k8200.eu/downloads/files/downloads/firmware_k8200_v2.2-marlinv1.zip

I think the setting E steps per mm must be wrong in my case. What do you think?


#4

Did you load the ini file or change the nozzle size


#5

yes, I changed nozzle size to 0.35mm.


#6

Did you do the last step?

DO NOT FORGET TO RELOAD EEPROM SETTINGS

When you have uploaded a newer version of the firmware you must not forget to reload the EEPROM settings. This will update the stored values on the printer as these are not updated via the Arduino upload process.

If you have an LCD module you can go to the SETTINGS menu, then scroll down until you see RESTORE FAILSAFE , access this menu and the firmware will load the new values into the EEPROM, next choose the STORE MEMORY menu (also in the SETTINGS menu) to store the new values.

If you do not have an LCD module you can do this via Repetier. Go to the CONFIG menu on the top and then choose FIRMWARE EEPROM CONFIGURATION. Then press the RESTORE FACTORY SETTINGS button.

DO NOT FORGET THIS STEP!!


#7

Well seems that you have done all…

Did you check in Cura Menu->Settings->Printer->Machine Settings->Extruder->Nozzle size ?
and there is also ‘Line Width’ and ‘* Line Width’ somewhere in the settings.


#8

I have found the mistake :grinning:

I made a z-axis upgrade in the past. During this upgrade I had to change the DEFAULT_AXIS_STEPS_PER_UNIT setting for z-axis in the config file. My mistake was to copy this modified line to the new config file. So, the setting for e-steps was overwritten. Now it is very clear to me why there was so much extrusion :wink:

Shame on me :woozy_face:

Many thanks to all for the support.


#9

Glad you found it.
Happy printing!