LCD printer only shows "status screen"

hello vertex

I just finished my assembly (k8400 single head) and installed my firmware.
If i start up my printer the LCD screen only shows the status screen.
I can’t seem to figure out how to get to the printer to show me the control menu

this way i can’t really control my printer
I hope you can help me

Push in the round black knob on the right of the display to select and open. Rotate the knob to move trough the menu or change values. If that doesn’t work, something went wrong during assembly.

Kind regards.

yeah i know i should be able to scroll trough the menu with the button on the right but if i twist or push this nothing happens

I know it’s a hassle but check the solder joints for the encoder.
Maybe one broke when you put the knob on.

Same thing happened to me. The steps I followed:
[ul]Powered printer for the first time and Menu worked with the pre-loaded firmware.[/ul]
[ul]Installed the M1-V1.4-H1 (for single head config.) Menu no longer worked. It flashed when the button is pushed but immediately returns to Status screen.[/ul]
[ul]Installed the M1-V1.1-H1 (in case it is a new bug.) Same thing as for 1.4.[/ul]

M1-V1.4-H2 works but M1-V1.4-H1 does not.
There are significant code differences between the two, far more than just print-head configuration. I don’t think M1-V1.4-H1 is valid.
I was able to modify my M1-V1.4-H1 to get the menu working again, so it is definitely a firmware issue.

Found a very old link of the first working version shipped for a single head: …
Obviously it does not have any of the later bug fixes, but at least it will help us while Velleman solves the firmware issue.


Thank you for mentioning this problem, we will try to replicate this problem and see what can be done.

Can you post what version of the Arduino IDE you are using to flash your printer?

I am using Arduino 1.6.6, which is a newer version than suggested in the documents.

For interest: Connecting in the Printhead reduces the problem (Step 1: Turning on the printer for the first time, suggest disconnecting the printhead.) It still occurs, but much less frequently. Using the dual head version ignores printhead zero, which is most likely why it behaves differently.

[quote=“Marius”]I am using Arduino 1.6.6,[/quote]Versions older than the 1.0.6 a known to be somehow incompatible with the Marlin software and generates errors after upload.

Try reinstalling the firmware with the recommended 1.0.6 version.