MAXTEMP error and heating 400C without command after shorted circuit


#1

I made i silly mistake today, i had to change connection to printhead, cause of burned pin (typical issue) and i cut all 10 wires at once when the printer was ON :frowning: The printer turned off and 12v led lighting connected to the same power supply also and i smelled some electrical aroma. After i finished new connectors i swiched printer on, everything looks good, but after a while smoke came out, PLA started to burn. Heating is going up after turning on printer, without any command, target temperature is of course 0, on both heads is the same problem. Temperature goes up to 400C, i don’t expect problem like this, rather oposite.

So right now i don’t know what to do, mainboard looks good i don’t see any burned elements on it.
I checked the wires are connected in a proper order, so cause must be related to shorted circuit.


#2

I checked motherboard and i don’t find any burned elements.

If replacing motherboard will be necessary i would like to convert motherboard to andurilo and ramps 1.6, but how many parts needed for this operation? vertex lcd and sdcard can be used? how about 15v power supply?


#3

I can’t say 100%, since I do not own a K8400 Vertex, but I have switched my K8200’s to use RAMPS 1.4 without any issue. I have even figured out how to connect the SD/LCD controller.

I have details about it in my write-up about converting an 8200 to dual heads. I think you will find that you can follow the RAMPS part almost exactly with your printer.


#4

I found your post about it and some more elsewhere. I bought arduino due and ramps-fd. So i hope i will not messe anything in assambly.


#5

I think you might have issues using the Arduino DUE because it uses 3.3V for the digital I/O, and can be damaged by higher voltages. There are also differences in the processor on that board, which could mean you will have to make some changes to the firmware.

The RAMPS board is known to work well with the Arduino MEGA2560.


#6

One guy make this setup in k8400, so it’s already working. RAMPS-FD means “for due”, so it is specially for this arduino.