Nano does not turn on, red led flashing

I have assembled the Vertex Nano and it does not turn on (more details below). Instead, both fans “pulse” (start and stop in short succession). The display remains dark. On the mainboard, near the printhead connector, I see a red led flashing.

Other observations:

  • powering via USB turns on the printer, including the display, and I am able to select various menu items
  • immediately after assembly, I was able to turn on the printer once (didn’t get as far as calibration yet) but now it is consistently not working showing the symptoms above.

Any idea for further diagnostics?

Many thanks for your support!

Seems like something wrong with the power on board i think could you post pictures of the Nano(you can use a image hosting site like


Thanks for the quick response. I’ll skip the images for now - I tried to turn it on this morning (after I saw your post) and it turned on just fine (only tried auto-home, didn’t have much time). While I am happy for now, I’ll continue to have an eye on it (will take a couple of days before I get to it again, though). Overall, seemed more like a timing or power problem (the power supply?) than anything else, just in case that helps coming up with ideas for further analysis…

Thanks again!

Ok. I was able to start a test print (spool holder light) and the printer has turned off mid print twice. I am now pretty sure that it is the power supply, as it’s led is not constantly lit either, but flashing (and very faintly at that). On a side note, I was able to consistently power on the printer (see start of this thread about how this does not work with the included power supply) from another power supply, but it’s ampere output is limited, so it is not enough to drive the motors etc.

Again, my question is: anything I can do to solidify this diagnosis or is the next step a replacement power supply?

Thanks much!

I woudln’t immediately replace the power supply.
Does the power supply get hot?

No it does not. I am now printing with a power supply with comparable specs that I happened to have. First observations:

  • turns on printer much more consistently (as in 100% of times)
  • test print seems to execute fine; if anything, with improved accuracy in positioning.

I’ll report back once I’ve seen more progress (it’s slow).

Ok. I’ve successfully printed the spool holder sample using my own power supply. If there is anything I can do to help with analysing what’s going on with the one supplied with the nano, let me know.