NEED Help


#1

Can someone make a movie how to Programm the Robot i have all the time error1


Arduino: 1.8.1 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\Doomee\Documents\Arduino\Sketch\VR408Scratch\VR408Scratch.ino:10:139: fatal error: SerialALLBOT.h: No such file or directory

#include <SerialALLBOT.h> // Do not forget to include the ALLBOT library, download it from the manuals.velleman.eu website

                                                                                                                                       ^

compilation terminated.

exit status 1
Fehler beim Kompilieren für das Board Arduino/Genuino Mega or Mega 2560.

Dieser Bericht wäre detaillierter, wenn die Option
“Ausführliche Ausgabe während der Kompilierung”
in Datei -> Voreinstellungen aktiviert wäre.


#2

Error while compiling for the board Arduino / Genuino Mega or Mega 2560.

This report would be more detailed if the option
“Comprehensive output during compilation”
In File -> Preferences.


#3

Looks like a syntax error.

Try changing:
#include <SerialALLBOT.h>

to:

#include <ALLBOT.h>

Looks like there has been a mix of Serial and ALLBOT headers.

If you plan to use Serial communication you don’t need to include Serial.h, Arduino compiler links it by default


#4

Looks like there has been a mix of Serial and ALLBOT headers.

If you plan to use Serial communication you don’t need to include Serial.h, Arduino compiler links it by default


#5

Hi there,

Maybe someone can help me with this. I do not understand what’s wrong…
I did nothing change in the libaries.

Code:

#include <Servo.h>
#include <ALLBOT.h>

ALLBOT BOT(8); //number of motors

enum MotorName {
hipFrontLeft,
hipFrontRight,
hipRearLeft,
hipRearRight,
kneeFrontLeft,
kneeFrontRight,
kneeRearLeft,
kneeRearRight
};

int sounderPin = 13;

void setup() {

//NAME.attach(motorname, pin, init-angle, flipped, offset-angle);
BOT.attach(hipFrontLeft, A1, 45, 0, 0);
BOT.attach(hipFrontRight, A0, 45, 1, 0);
BOT.attach(hipRearLeft, 9, 45, 1, 0);
BOT.attach(hipRearRight, 4, 45, 0, 0);

BOT.attach(kneeFrontLeft, 11, 45, 1, 0);
BOT.attach(kneeFrontRight, 2, 45, 0, 0);
BOT.attach(kneeRearLeft, 10, 45, 1, 0);
BOT.attach(kneeRearRight, 3, 45, 0, 0);

//INIT sounder
pinMode(sounderPin, OUTPUT);

//wait for joints to be initialized
delay(500);

}

void loop() {
// put your main code here, to run repeatedly:

}

Error:

Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Uno”

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::ALLBOT(int)’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::ALLBOT(int)’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::~ALLBOT()’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::~ALLBOT()’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::operator

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::attach(int, int, int, bool, int)’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::move(int, int)’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT.cpp.o (symbol from plugin): In function `ALLBOT::ALLBOT(int)’:

(.text+0x0): multiple definition of `ALLBOT::animate(int)’

sketch\ALLBOT.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::move(int)’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::reset()’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::prepare(int)’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_AsyncServo.cpp.o (symbol from plugin): In function `ALLBOT_AsyncServo::ALLBOT_AsyncServo()’:

(.text+0x0): multiple definition of `ALLBOT_AsyncServo::tick()’

sketch\ALLBOT_AsyncServo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::ALLBOT_Servo()’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::ALLBOT_Servo()’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::flipped(bool)’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::offset(int)’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::attach(int)’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::write(int)’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

libraries\ALLBOT\ALLBOT_Servo.cpp.o (symbol from plugin): In function `ALLBOT_Servo::ALLBOT_Servo()’:

(.text+0x0): multiple definition of `ALLBOT_Servo::operator=(int)’

sketch\ALLBOT_Servo.cpp.o (symbol from plugin):(.text+0x0): first defined here

collect2.exe: error: ld returned 1 exit status

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.


#6

seems like you installed the library twice somehow.
Could you post screenshot from your arduino library folder?

Thanks!


#7

Hey,

Yes you were right. It works now.
image