NEW >>> K8090 8-Channel USB Relay Card


#41

Hello guys,

I’m trying to write a perl script to toggle my relays and I’m having trouble mainly because I’ve just started to learn perl for this project. Has anyone done that or can anyone tell me the hex sequence (for example to turn on the first relay)?

Thank you,
Mihai


#42

I too am trying to get my K8090 card to work with an iPad using the Apple app K8090 by Philippe. The card works perfectly from your demo program via my Win7 directly to the K8090 card. I did contact the developer, Philippe, who replied with a cryptic answer. When I returned an email to him (twice) asking for a better explanation, he never responded. I saw in this venue that others have had similar problems with this developer.

I realize that Velleman is not responsible for this third party program from Apple, but hopefully they could consider providing some solution so that non-programmers like myself could use the card as I intended via the iPad.

Thank you for your consideration and providing wonderful projects like this one.


#43

What is the problem and what was his cryptic answer? Maybe we can help in clearing things up


#44

I can not find the dll ??
can some please tell me where can i find it plzz


#45

You can download the DLL off the Velleman website in the K8090 section.

If you get it working with the iPad, please let me know what you did.

I never heard back from the iPad APP developer. I was hoping that someone at Velleman would contact him also to have him help get it working, or at least explain what to do to make it work correctly.

Thanks, Ellis in New Mexico, USA


#46

Here is the cryptic message I received from Philippe:

Philippe,

I did finally manage to get the configuration file changed and can now load the server file using my IP address and the COM port for the Velleman K8090 card (COM3). The server file appears to run correctly (no error indicated) but the iPad app does not find the server in my PC. I did set the IP address in the app to the same IP address for the PC. When I attempt to switch a relay ON or OFF, I get an error window that says “Server Not Responding”. Any ideas on what that problem might be?

I am using the iPad through my home wireless network, if that has any bearing on the problem.

Philippe,

I still need an answer. I am very anxious to get this iPad app running. Any help you can give will be much appreciated.

One would expect the app to run out of the box without having to resort to contacting the designer. Every other app I have loaded worked without this step.

Please help me resolve this issue.

Ellis Dawson


From: EllisDawsn@aol.com
To: philippe@milagro.ws
Sent: 3/1/2011 12:58:21 P.M. Mountain Standard Time
Subj: Re: Apple iPad APP problem

How can I verify port usage and how can I change that if it is a problem? Is that the port in the PC? Any suggestions will be greatly appreciated.

Ellis

In a message dated 3/1/2011 3:56:16 A.M. Mountain Standard Time, philippe@milagro.ws writes:
verify if the port 2233 is not in use by other apps.

Thank you for your help.


#47

Just a guess because I still need to build mine.

Do you have a firewall running on the server?
Have you tried to disable your virus scanner (just for testing)?

I hope this may help


#48

can I have the source code of the demo application in VB ?
thank you very much…


#49

I runned the Sample 2 in my VB 2010 express and i had this problem after adding the dll file as references

Any idea to solve this??
thanks any way


#50

Hi,

Just a guess.
Is the DLL in the same folder as your project?


#51

Why are you adding it as a reference? K8090D.dll is not a .NET assembly file


#52

hello guys

yes it is, I put it in bin folder

Because this is the only way I knew it,
plz Tell how to add the dll files

thanks for your cooperation


#53

You should take a look at the demo projects in .NET first to see how they work. There is a .NET library wrapped around the regular DLL which provides an interface to the K8090


#54

I just opened the Sampel01 and did not run OK
the same problem appeared to me
“Unable to load DLL ‘K8090D.dll’: The specified module could not be found. (Exception from HRESULT: 0x8007007E)”

can you plz explain to me


#55

Put the DLL where Windows can find it, the easiest way is to put it in the ‘C:\Windows\System32’ folder. It is strange though, since the installer should already have done this for you…


#56

I just put copy of dll (Velleman.Kits) in ‘C:\Windows\System32’ folder, and the same problem still appearing


#57

It can’t find K8090D.dll, so you need to put K8090D.dll in the ‘C:\Windows\System32’ folder.

The file Velleman.Kits.dll is a .NET assembly which you can add as a reference in a .NET project.


#58

where can I finde this file K8090D.dll

Very sorry, I’m so beginner in this field


#59

Any Help!!
:cry:


#60

Ijust solve the first poblem
Now I just have another one

so what’s wrong this time??