No connection out of the lokal network (wifi)


#1

i install the vm204 app on my android smartphone if i scan to discover the vm204 i have always have to try twice before the app finds the module then we saved it with name and password and everything works great.
i can control it te inputs sends mails everything is okay.
but if i try to reach the vm204 from out of my lokal network i don´t can get connection.
can you connection with the webserver just if just have saved the lokal ip port 80 en the lowest button stand on connect to lokal network everywhere in the world?
i have try this and i have try with my WAN ip and a poort that i forwarded but everytime i get on the app screen next net::ERR_CONNECTION_REFUSED and before you have inlog http:/admin:VM204(wanip):port/
if i not fill in my wan ip and port and i do the lowest button connection lokal out then i get a white blanck sreen with nothing in it can somebody help me?
if i scan my portforwarded then it say that it is closed and i have an other port that is forwarded for a ip cam and this works perfect and the scan says open.
i check it it is not a port that my provider used it is not on their list.

also i have installed the vm204 software on my pc but i can not open the discovery software the firmware updater works perfect i have windows 10 now i chanche the settings via app (wifi)

can somebody help me i will control the vm204 anywhere thats wy i buy it.
mvg patrick


#2

Hi
if you long press on a relay card in the app it should give you the option to edit it. There you fill in your external IP address and port. Also it’s important to select which IP you will use when you will connect to the card. You can select that with the “Connnect to local network” slide option. Maybe it’s off screen it’s on the bottom of the settings page.


#3

hi
i know this that you by edit can fill in external ip and the port you have geforward and that you on the bottom can select your communication lokal or not.
but if i use lokal and ip and port 80 if my smartphone is in wifi in lokal network everything works perfect.
but if i go out of wifi and i´m not on lokal network i can not have connection.
even if eye set it on no lokal and i have fil in my external ip and the port that i have geforward.
than i get the info webpagina on http://VM204@my external ip : port/ can not be loaded because
net::ERR_CONNECTION_REFUSED
my question is do i need this external ip and port for to get communication to the vm204 ore is it normaly posible to get even out of lokal network to get connection to vm204 via port 80 and the webserver.
i have programmed mails notification this is no problem that this reads me even i´m out of lokal net work.
i have also a ip camera and this works perfect with the portforwarding on different port.
i have checkt it and im not yousing some ports dat is taken by the provider.
also i have checkt on a website portscanner the ports that i use and with the wan of the vm204 disconnected it is filtered and connected it is closed if i do the same withe ip camera it is filtered en camera on it is open.
it is like the port even i say it have to be open it dosn´t do that ore is it posible that the firewall port for some reason don´t let me go to the vm204 because he see it like a danger apparat?
i don´t find a solution.
mach greats from patrick and sorry for the some bad engelish


#4

hi again
i have now turn my ports i have give the port from ip cam on the vm204 and otherwise and the same result the ip cam works perfect and the vm204 not at all even as i do back the portscan it say with the ip cam it is open with the vm204 it is closed.
and i turn them back the portforwarding and than is it back the port vm204 stay closed and ip cam is open.
now i know that i can open the port of my provider router but for some reason the firewall blocks all the time the vm204 even it not gowing to port 80 want i think that if i out of lan with mi phone i have have to get connection true webserver via port 80 with the vm204 an only if i say that it is via no lan i have to have external ip and port.
i also tryed with DMZ on the lokal vm204 ip even then i don´t get connection.
i don´t now wy my router modem blocks every in comming communication with the vm204
i think out it works becouse it sends mails i don´t know where the troubel is.

greats patrick


#5

hi
were almost a month away and still no solution for my problem.
i have to say it here in english for a company that is in gavere about 40km of my home Belgium.
is their nobody to help me???
i have buyed your vm204 and in lokal net werk wifi it works great with the app but if you go away in wide area network than you can not have connection with it.
can you have connection everywhere if you have ip lokal and port 80 in the discription and the bottom switch to lokal???
in this situation i have a blank with page in the app.
i´m alredy reset my modem an other things nothing works i have also a ip camera and this works perfect with the portforwarding if i do a scan on this ports with the ip cam he say open with the vm204 he say closed even with portforwarding???
and via port 80 is it a blanck with page not normal.
now i have also a problem with the covery app the icon is on the buropage but if you clic on it nothing happens.
i already instal like 10 times the software and the firmware works great.
i have windows 10
now i buy the vm204 for to control it from outside like you say it sut do.
wher can i go if the product dos not do what it have to do???
mvg gusse patrick


#6

Hi

Just checking you wrote “http://VM204@my external ip : port/”

but it should be http://username:password@my_external_ip:port/
Did you forgot to enter the username?
Could you post a screenshot of your settings in the app?

Thanks


#7

your right it is http://VM204:password@external ip:port/ can not be loaded because this reason
net::ERR_CONNECTION_REFUSED
it looks like my firewall of my router modem (telenet) dosn´t wanna let me connect to your vm204 even i forward it on an port.
if i´m right even if you just edit lan ip (dhcp) and port 80 and bottom on internal connection than you have also can have connection from everywhere even out of wifi but that dosn´t work i have a blank white screen when i go out of wifi.
and if i type my lan ip in a browser i can after i login have contact with the vm204 but that dosn´t work with the external ip:port.
the strange thing is that i have a ip camera that works perfect with the port forwarding i have alredy switch the ports to check them and the ip cam dos work perfect with it i have also scan the ports via a website portscanner and with the ip cam it say open with the vm204 it say closed even when it is forwarded and if the card is of the network it say filtered.
i alredy reset my modem i try erverything but nothing change.
if i can i try it on a other network modem for to see if it is not my modem that reffused your vm204 card.
i also have 1 network stopcontact and this you not can forward it it works with port 80 and his web server and i can used everywhere even out of wifi.
i try to send you some screen shots by anserwring your mail because everybody can se my ip´s here.
grts patrick


#8

hey there
its me again i have try the vm204 in some other network then at my home network but the same trouble.
if you just connect it and scan with the app and instal with usersname admin and VM204 password everything works great whiting the wifi network but once u get out of it the app gifs a blank screen and their is no connection.
and it like me it has to be possible that just with the intern ip usersname and password and bottom connection on intern it has to be possible to get connection everywhere???
even you do port forwarding and you gifs your external ip and you change the bottom in the app on external connection then you can have nowhere any connection everytime you get a message of no connection possible.
now i think it is not my and my friends network gifs the problem or it is the app of the vm204 that not working well.
and strange but today i can not find the vm204 app anymore in the google play app store anymore???
and the link in the manual dos´t work no more.
what is happening here?
i see at the moment one sullution anymore and that is that i go to the store where i buy your product and thei can proef me that the product works well with the app.
i think that it is no coincedence that it dosn´t work in a telenet home network and also not in a proximus home network.
now i see now options anymore to get work do you???
grts patrick


#9

o buy the way everythime a try to test it i do a factory reset and start from beginning for testing.
the pc software the vm204 discovery stil dosn´t works on my pc i try everything from compactibiliteits troubel and more.
but nothing helps i can instal everything the short cut is on the screen but if i click on it nothing happens and the firmeware software works good.
now i instal the same software on my wife laptop and their it works well??
the only defference is that see have original win10 and with me it is an upgrade from win7 to win10 ore there has to be some conflict with sommething do you have an idee what i can try to get it work???
grts patrick


#10

As for the discovery software.
Do you have Java installed on the Laptop?


#11

As why you can’t reach your VM204 from outside is something we can’t do anything about it.
You can access the card from your local network so everything is working fine.


#12

hi there im back
i have found the problem why i don´t have connection from outside my network with the vm204.
i was thingking that when i fill in the ip en ports in the app and press save that it also was saved in the vm204 kaart.
this is not you have first to have chance the ip and ports in the settings of the vm204 and press save and reboot.
on that moment you don´t have connection on this moment anymore and than you have to chance the ip and of ports in the app and make your portforwarding in your modem.
the explonetion that you also can let it work with the port 80 it is not possible via the extern net i think because the provider bloks the port it just works on this port if you do an portforwarding on the 80 but you can not use anything more on the 80.
if you want to let it works on the WAN than you have to make your personal port than it works great.
at home i have internet provider telenet but i try it also on proximus it was the same problem i think thei also bloks the port 80 for in comming connection.
my problem was i change everything in the app and modem but not in the vm204 card at first and there the port was always on 80.
i hope i can help some other guys with my explonation maybe if it´s posible you can set it in the users manual that you first have to chance the ip and port in the vm204 in the settings and than in the app.
many greats from a happy men gusse patrick


#13

Hi patrick1972,

Yes you have to adjust both settings. But if you changed the settings first in the card and go back to the app and you do the scan again it sends it’s new port and it should update.

Btw you can still access the card even if you changed your port.
for example you entered 192.168.1.204 with port 100
you can surf to http://192.168.1.204:100/ and you should see the cards interface