No response from printer

Hi all
I’m completely new to forums so please bare with me.
I’ve had my K8200 for a few years now, in the early days it worked fine with a lot of good prints. However it developed faults which I couldn’t get to the bottom of so it hasn’t been touched now for a year or more.

I’m wondering if there is a way to do a “factory reset” kind of procedure so I can start from scratch. I can’t remember if I’ve tried updating the firmware etc and can’t seem to find simple instruction on how to check it and reinstall or update it.

I’ve downloaded the Repetier software from the Vellerman site, set the com port etc and although it connects to the printer it won’t actually do anything, even in manual control. The temperatures are reading “0”
There are a red and a green LEDs illuminated near to the usb port that come on as soon as the usb cable is connected.

Thanks in advance for any and all help.
Greg

You say you are able to connect to the printer in Repetier. Do you see messages coming from the printer, or does Repetier say something like “5 messages pending…?” If you don’t see messages from the printer in the Repetier control panel, make sure you have the right COM port and BAUD rate (250000) selected.

If you are communicating with the printer but getting zero temperature readings, shut it down and check all of the wiring, particularly looking for loose connectors on the controller board.

Since the red and green LEDs are on you should check the power supply.
Measure the voltage on the blue terminals you should see 15Vdc

OMG! Believe it or not my job title is “Technical Supervisor”, I have a R&D team and a maintenance team. I constantly tell them all to start at the beginning when fault finding!!

I’ll keep this one quite I think.

Thank you Dr Vegetable for your reply.

Thank you Wrong Way… The fuse in the plug had blown.

Ironic that both your usernames have just summed me and my performance up so accurately.

Thanks again

No problem

I hope this helped.