No succesful connection between the computer and printer


#1

Dear Velleman,

I has now taken me a very long time to assemble the K8200 3D printer, due to many errors in the assembly manual. I have downloaded when I got the kit.

Now I have reached the point where drivers (ports) are installed (Win7) & Repetier-Host V.0.84 are installed.

  1. When K8200 is only connected via USB port, green & red diode lights on the main board. Repitor-Host is set as “Disconnect”. 4 commands are waiting in the info/manual control.

  2. When power is turn on (220V) and on main board measeured 15,4V a green diode in middle of main board blink 2 times and the above green & red diode turns of.

In non of the situations I get the info in the log view : (page 540 in your web manuel)

FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup FIRMWARE_URL:http://www.K8200.eu -
velleman.eu PROTOCOL_VERSION:1.0 MACHINE_TYPE:K8200 - 3D PRINTER EXTRUDER_COUNT:1

or the extruder and bed temparature.

Why ?, What is wrong ? I assume you have made your manual in the rights steps or ?

I need urgent help. Please give me a detailed roadmap to finish so I can print.

Do you have any person in Denmark that have any knowledge about the printer that I can contact ?

I need help ASAP.

Best regards,

Jannik


#2

Hi jannik,

the LEDs lighting up when connecting the USB cable and powering up is as expected.

When you press the connect button at that point, what does the log show? Is the “4 commands waiting” text in the manual control tab still visible?

Cheers
kuraasu


#3

Hi Kuraasu,

When I press the connect button so it is set to “Connect”, the manual control says disconnect, but the 4 commands is still shown in the info “buttom of the page”

The info says in 4 lines. (only info dot is blue in the “show in log”)

  1. Open GL Version: 2.1.87.87
  2. Open GL extensions: GL_AMDX_vertex_shader_tessellator_GL_AMD_draw_buffers_blend GL_AMD_performance_monitor GL_AMD_texture_texture4 GL_ARB_color_buffer_float GL_ARB_copy_buffer GL_ARB_dept_buffer_Float
  3. Open GL redenderer: ATI mobility Radeon HD4570
  4. Using fast VBOs for rendering is possible

What can I be missing, I am just following the manual step by step.

Best regards,

Jannik


#4

Hi jannik,

check the Printer Settings. You should have two profiles there, one “default” set to a “Virtual Printer” (Connection tab), and one created by yourself, called “K8200” or so, set to Serial Connection, with the correct COM port for your printer, baud rate 250000, and Receive Cache at 63. In Repetier 0.90, also make sure Reset on Connect is set to Disabled.

If those settings are present and correct, click the right edge of the Connect button (the small triangle). The two profiles should be visible. Chose the K8200 profile. Does the log now show the “FIRMWARE_NAME:Marlin …” line?

You can also test connecting to the “default” virtual printer. This should always work and produce a similar ID line, “FIRMWARE_NAME:RepetierVirtualPrinter …” and so on.

Cheers,
kuraasu

PS: you don’t have to chose the profile each time. Pressing the Connect button will connect to the last used profile, so once the K8200 profile is set and working, it’s just one click.


#5

Hi kuraasu,

Thank for your feedback and I am sorry for my late respond due to long hours working.

My computer downloaded the driver without problem when I connected the printer first time. Now I have my normal printer set as default and the K8200 (named as Not specified printer “FT232R USB UART”, when I look in “devices & printers” at the computer. I can not make “FT232R USB UART” as a default printer.

When I look closer at the Not specified printer “FT232R USB UART”

I Click on this printer and under Fan : Hardware

Unit function (it says below)

Name Type

USB Serial converter USB-controller (Universial Serial Bus)
USB serial Port (Com 19)Port (COM & LPT)

I click (USB serial Port (Com 19), and new window open.

Fan : Port setting

Bits per second : default (now) 9600, options to choose “adding itself” starting with 300, meaning 300, 600, 1200, 2400, 4800, 9600, 14400, 19200, 38400 and so on.

Data bit : default (now) 8, options to choose 7.

Parity : default (now) none, options to choose even, odd, mark & space.

Stop bits : default (now) 1, options to choose 2.

Flow control : default (now) none, options to choose Xon / Xoff, hardware &

Fan : Drivers

Driver version : 2.8.30.0

What to do ? I have no Idea of what to look for ?

I am for sure not a specialist is this and had really hoped that Vellemann had made a video about this + more detailed decribtion.

So far the only feedback is from you and I realy appreciate that. I really think that Vellaman have a big problem in support, including putting a product on market with so many errors, that users shall solve by themself in this forum.

I will see how many days it will take Vellemann to respond to me, but I guess all you in this forum will be to a greater help, or ? Do you read this Vellemann ?

Best regards,

Jannik


#6

Dear Jannik,

All the settings for the printer connection need to be made in the repetier software.
Under “printer settings” make sure everything is set as folows:

then:

apply power to the printer
plug in the usb
find out the com port of the printer in device manager and make sure the settings mentioned above have the correct com port selected (save the settings when you needed to change the number of the port).
press the connect button in the repetier program (the button text will change from connect to disconnect this is normal)
if you do not see the log entry as specified in the manual, press the small button on the right top corner of the motherboard on the printer. It is possible that ofter the press of that button the connection will be succesfull


#7

I too have the same issue, I have tried step 7 and get the same response

Binary sketch size: 52,104 bytes (of a 258,048 byte maximum)
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

Repetier connects to the board but does not recognise the printer firmware. I have tried the different repetier versions, and also replaced the board through Maplins the UK vender.

I am at a loss as what to do next, any help would be much appreciated.

thanks,
Alex


#8

Jannik,

Did you get the problem resolved?

thanks,
Alex


#9

Hi Alex,

[quote=“alexgoodhand”]I too have the same issue, I have tried step 7 and get the same response

Binary sketch size: 52,104 bytes (of a 258,048 byte maximum)
avrdude: stk500v2_ReceiveMessage(): timeout
[…]
avrdude: stk500v2_getsync(): timeout communicating with programmer[/quote]
since you quote avrdude messages, you probably mean updating the firmware when you say “step 7”, right? Otherwise, please specify in more detail where you got those error messages.

If it’s indeed the firmware update, when do those messages appear? Before compiling? After compiling, but before uploading? Or after the actual upload, when the Arduino IDE tries to re-read the firmware to check for possible transfer errors?

[quote=“alexgoodhand”]
Repetier connects to the board but does not recognise the printer firmware. I have tried the different repetier versions, and also replaced the board through Maplins the UK vender.[/quote]
How do you deduct that there’s a connection, but not to the firmware? What’s in the log in Repetier Host?

Cheers,
kuraasu


#10

The avrdude message comes out upon trying to upload to the board. The compiling works, uploading seems to work until the bar gets to about 90% and then times out.

The repetier detects the board, as once connected in the printer information box it is still sending bytes to and unknown printer. With no firmware information.

thanks,
Alex


#11

That’s approximately the point at which the check starts, so the actual upload is probably finished by then. In the preferences dialog, you can disable the check and test whether uploading works without error message. Make sure the correct board and COM port is selected, plus JPROG shorted.

Upon startup of Repetier Host, click Connect. The log should look like this:

OpenGL version:2.1.2 OpenGL extensions:[...] OpenGL renderer:[...] Using fast VBOs for rendering is possible FIRMWARE_NAME:Marlin V1; [...] echo:Active Extruder: 0If yours differs, post it here (you can of course cut the long lines that just endlessly list options like I did, but leave the important stuff in).

What message is shown in the blue box in the Manual Control tab?


#12

unfortunately that still doesn’t work, the same avrdude timeout error came up. The pins were shorted, and the board and COM were correct.

under printer information it now doesn’t recognise any connection information.

in the log, it stops after ‘using faster VBOs for rendering is possible’

and in the manual control it shows ‘4 command waitiing’

thanks,
Alex


#13

Hi Alex,

if by “printer information” you mean anything from Windows’ Printer folder: disregard it. It’s the wrong location to set parameters for this type of printer, which is from the computer’s point of view just a simple serial device of unkown function.

The “commands waiting” message is indicative of a missing connection to the firmware, i.e. the USB chip is active, but the ATmega is not. The power supply is connected and switched on? Voltage on the screw terminals measures about 15 V? What LEDs light up when you power up the board, most importantly LD1 (green, at the lower right corner of the ATmega, should blink twice), and LD5 and LD6 (red and green, next to each other and close to the USB port, should light constantly when powered up, go dark when connected and blink upon data transfer).

Cheers,
kuraasu


#14

the printer information is in the repetier toolbar.

when I power up, ld1 flashes twice then nothing, without power and just usb ld5 and 6 are lit up constantly then when powered up the lights go out.

the board is receiving 15v.

I’m a bit lost to be honest.

thanks,
Alex


#15

Ah, i see. Sorry, my bad.

What operating system are you using?


#16

not a problem, you don’t understand how appreciative I am of your help.

I am using windows 8.1 but I had the same issues on 7 as well.

thanks,
Alex


#17

Hi Alex,

what was the initial state of the board when you got it? Did it already work once and then failed or is this the same state as from the beginning?

Any response from the motors when the board is powered? There once was an issue with a test firmware …

What firmware version did you try to upload? The one from Velleman? V1 or V2? Or from GitHub?

Cheers,
kuraasu


#18

the first board I had kept repeating ‘echo command unknown’ in the repetier log.

this second board doesn’t have that issue, I have tried v1, velleman and github.

I haven’t had any response from any component unfortunately. Either physical or digital.

thanks,
Alex


#19

That’s not true - the LEDs light up exactly as they should. Optimism!

With the board connected and powered, open the Arduino IDE, check that the COM port setting is correct and select the Serial Monitor from Tools. Set “newline and CR” as line end and 115200 baud (should be 250000 ideally, but that’s not in the list). Enter “M105” in the above field and click Send. Does the board respond?
If the response is echo:Unknown command:"…", try again, two or three times, to clear and refill the send and receive buffer.


#20

LD6 briefly lights up,as in less than a second.