No succesful connection between the computer and printer


#21

but no text in the ‘COM4’ serial monitor window.


#22

COM4 seems quite low for a virtual port - but it is the correct setting? I.e. it is visible in Windows Devices Manager that it disappears when the board is disconnected and reappears when being reconnected?


#23

Yeah,
Ports (COM & LPT):

Communications Port (COM1)
USB Serial Port (COM4)

then disappears when I disconnect.


#24

Ok, thanks for checking anyways.

When you short the JPROG connector, does LD1 blink twice? Same when pressing the reset button?


#25

it did do, but it doesn’t anymore.


#26

yes it does, I tried again.


#27

That’s ok then. There’s a capacitor, the reset depends on whether it’s loaded or not and which of the two pins you touch first …

So far, everything checks out quite well. Could you give it a try and reload the firmware one more time? Or actually, two or three times, if the error message reappears? Sometimes it’s just a glitch in the USB/serial connection and suddently everything works when retrying. I’d suggest the V1, to be on the safe side, but to be sure please have a short look into the Configuration.h and doublecheck that the baud rate is set to 2500000. And, but this is for the newer versions and not present in V1: serial port to 0 (so it won’t clash with Windows’ setting).

Also, the short original USB cable might be worth a try, if you haven’t done so already.


#28

configuration.h;

baudrate =250 000
serial port = 0

repeated upload 3 times, same error unfortunately. I will try another USB cable.


#29

I’m afraid if that doesn’t help I’m at a loss.

It should still be possible to use an external programmer (another Arduino board or a special programmer) for reloading the firmware through the ICSP port, but I reckon you don’t have such a thing at hand since then you would probably already have tried.

A LCD panel like the Velleman VM8201 could be used to test whether the controller is responsive, but that would require an active firmware with LCD support enabled, i.e. V2 or current version from GitHub, so no gain there without first updating the firmware …

As said before, all the usual (hardware) indicators are ok. In principle, a broken UART line between the USB chip (FT232RL) and the ATmega would produce such a result, or a defect at that location inside the ATmega. Not impossible, but also not heard of here until now. Do you have a bit of knowledge in electronics, i.e. how to handle a multimeter around SMD/QFP ICs?

Last resort: doublechecking Repetier Host’s settings. COM and baud should be clear by now, Reset on Connect shall be set to Disabled (but that would not have hindered the Arduino Serial Monitor to connect), otherwise as shown in the online tutorial.


#30

I’m a mechanical engineer, so very basic electronics. Under guidance I would be confident using my multimeter on my chip, but I wouldn’t know what I am looking for.

I tried the other cable, but again nothing unfortunately.


#31

Dismount and disconnect the board for this, you’ll need good light, perhaps a magnifier glass can be helpful for the small pins.

The paths are as follows:

A-G: TxD path
H-M: RxD path

A, H, G, and M are pins (careful to contact the right one:
A - pin 1 of FT232RL
H - pin 5 of FT232RL
G - pin 2 of ATmega2560
M - pin 3 of ATmega2560

B, C, E, F, I, K, and L are vias that transfer the circuit path between different layers of the PCB. They are easy to contact with the measurement tips, so it’s a good idea to start with these.

D and J are the resistors (R18 and R19, 10 Ω “10R0”) as visible from the schematic (top right, TxD/RxD to PE0/PE1).

Apart from the resistors, which should of course have about 10 Ω, all connections within each path should measure as short circuit or closed connection with negligible resistance.


#32

Brilliant, thank you. I shall try it first thing tomorrow, i will upload my findings.

i really appreciate your help for this.

thanks,
Alex


#33

I just tested the board, everything seems as you said, between pins
A-G=10.9ohms
H-M=10.8ohms


#34

Hi Alex,

although that’s positive, it’s also bad since it means we still have no idea where the error is located.

Anything else available that could help? An oscilloscope, programmer (ISP), another Arduino, PC with different operating system to test, or a Raspberry Pi perhaps?

Possibly another exchange is in order. You mentioned Maplin as your distributor, online or store? In case of the latter, perhaps you can take a laptop, USB cable and power supply with you to the store, or find some other way to immediately test the new board.

Cheers,
kuraasu


#35

I have a pi available, I was reading the same thing on the other pc.


#36

As in same errors. Its running win7 as opposed to win8.1.


#37

Hi Alex,

so, Win8.1 won’t connect, Win7 won’t connect either, right?

Did you test it with the Pi, e.g. using OctoPrint (or rather OctoPi, which should already include the tweaks to enable 250000 baud connections)?

Cheers,
kuraasu


#38

I set up octoprint though my pi, it gave out some more error information.

Changing monitoring state from ‘Offline’ to ‘Opening serial port’
Connecting to: None
Unexpected error while connecting to serial port: None OSError: ‘[Errno 2] No such file or directory: ‘None’’ @ comm.py:_monitor:497
Failed to open serial port (None)
Changing monitoring state from ‘Opening serial port’ to ‘Error: Failed to autodetect…’
Changing monitoring state from ‘Offline’ to ‘Opening serial port’
Connecting to: None
Unexpected error while connecting to serial port: None OSError: ‘[Errno 2] No such file or directory: ‘None’’ @ comm.py:_monitor:499
Failed to open serial port (None)
Changing monitoring state from ‘Opening serial port’ to ‘Error: Failed to autodetect…’
Changing monitoring state from ‘Offline’ to ‘Opening serial port’

any thoughts? I’m stumped.


#39

Hi Alex,

an error in the UART connection is more and more likely. The USB part seems to work well, since the VCOM port is detected, but apparently it is not even possible to establish even the most basic serial communication between host and ATmega.

At this point, I can only suggest to replace the board (again). Hopefully it’s just bad luck that you got two lemons in a row. Perhaps Velleman would be willing to take over without the need to go through Maplin?

Cheers,
kuraasu


#40

Any idea how I can get in contact with a Velleman representative, I can find no contact information on their website.

I must thank you for all of your help once more.

thanks,
Alex