P8061-2: USB Connection fails


#1

I baught a used P8061-2 Card, which fails to connect to the PC USB Interface:

When I apply the 12V DC Power, LD12 “RUN” starts flashing and LD13 to 20 are permanently illuminated (as described).
When I plug in the USB-Cable, LD10 “POWER ON” gets on, but the PC (Windows 7 / 32 Bit) does not report an unknown USB Device to be installed.

My visual Inspection did not detect any weak points of the assembly quality. What steps could I take to fix the Problem?

For my understandingthe PIC18F2550 is controlling the USB Interface. In case this chip or the firmware is damaged, do you offer the hex-File to be reprogrammed or a pre-programmed replacement PIC controller?

Thanks for your Help
Thomas


#2

Did you check this in the Device Manager?
Doesn’t the Device Manager refresh the list when you plug the USB cable to the K8061?
Maybe the USB cable is defective.


#3

Yes, I checked this with Windows-R Key and then devmgmt.msc several times.
It never reports an unknow device to be installed.

I also took a second, brand new USB cable which gives the same result.

When I start the “K8061 TEST & DIAGNOSIS UTILIY Rev 1.1”, with correct Ch# and push the “Open” Button, the Result is “Card not found”.

What is the meaning of the flashing “RUN” LED? From the instructions, I understand that it should be set permanently.


#4

This is the result when the USB driver for the K8061 is not installed.

The LED is flashing until the driver is installed and USB connection completed.

When the driver is not installed and the USB cable is connected you should see the K8061 under the “Other devices” in the Device Manager:

do you see it there?


#5

No, the Device Manager does not show any unknown Items. It even does not have the “Other Devices” classification.


#6

It seems that your K8061 may be defective.

Can you test it in other PC?


#7

Meanwhile, I have checked all the passive components around the USB-Controller IC3 (resistors, capacitors, crystal) for correct values with no findings.

So I assume now, the USB-Chip PIC18F2550 is not working as expected. My Programmer (MiniPro TL866) accepts the PIC18F2550 to have the correct signatures, but I assume the device is protected (see screenshots made after readout).

I also checked the behaviour of the board on a second PC with the same result. Would it be possible to send me the hex Files for both processors so that I can reprogram them?


#8

Yes, it is protected.

Sorry, for copyright reasons Velleman never supply .hex code.
You can return the defective processor for inspection/exchange to:

Velleman Projects
Legen Heirweg 33
9890 Gavere
Belgium


#9

OK, what do you charge for it?


#10

Sorry, no exact pricing.
As a one-time courtesy, here is the link to download the hex file for the PIC18F2550:
https://app.box.com/s/9hri55myidfdu5d6z7wozvqt8aif41gn
The link will be valid for 1 day only.


#11

Thank you very much!

Since I am more familliar with AVR Programming, one question before I start to overwrite the PIC18F2550 contents:

When I load the HEX-File into my Programmer, I see that it modifies not only Code (Flash) Area but also EEPROM and Config Bits. In EEPROM for example I see “IC3: VK8061USB Rev: 1.3” So it ist all-in-one, and I don’t need to figure out what are the correct Config. Bits ?


#12

Yes, you can use the hex file as is.
If you doubt, you can always send the PIC for check/reprogramming/replace to Velleman.


#13

Thank you very much again! As you can see below the Board is detected and installed now.
success


#14

I’m glad it’s working for you now!


#15

Good day
I have the same problem than Thomas, I just test it on a new computer with the new Win 10 64 bit DLL and still the same.

Can you pls help me with the firm ware for the PIC18F2550 !

Regards
Danie


#16

Is there the K8061 device seen in the Device Manager under Other devices?
If yes, you can install the driver.
To install the driver on 64 bit Windows you have to disable the driver signature enforcement.
Please use the latest driver K8061 driver update v4.0.0.0 available here.

Here you’ll find the instructions how to disable driver signature enforcement in Windows 10
I prefer to use option two.


#17

Hi

No I tried it on XP when I bought kit and later on WIN 7 32bit and now on a new computer with WIN 10 64 bit and still the same, Windows does not see the K8061 at all an do the same as Thomas has explanation, is was by mistake I come across this forum and see that I was not the only one with the problem. If I have to bay a new and tested PIC, I would like to get the board working. I will follow the instructions on the links, but if Windows don’t pick up the device I don’t think it will work…

Regars
Danie


#18

Strange problem, indeed.
Have you tested with other USB cable?
Have you checked all soldering, especially the USB connector and IC3?
If no help, you can return the PIC18F2550 or whole kit for inspection/repair to:

Velleman Projects
Legen Heirweg 33
9890 Gavere
Belgium

If you have PIC programmer, you can first try reprogramming the PIC18F2550.
Here you can download the HEX file for it.


#19

Thanks very much.

I tried different USB cables, check everything I can think off. I also have the K8055 board and it works fine up to WIN 10 64 bit.

I will give the programing of the PIC or replace the PIC with a new one…

Thanks

Regards
Danie


#20

Good Day

Thanks very much, I reprogram the PIC and now windows see the K8061 board, Just battling to install the driver on WIN 10, Tried om my WIN 7 Laptop, everything install, but Demo software dom’t see the K8061, will work on the at least I can see the K8061 in Device manager correctly installed.

Thanks for helping me…

Regards
Danie