PcLab200 doesn't find PCSU200

I’m trying to use a Velleman PCSU200-oscilloscope, but the PcLab200 is unable to detect that it is connected to the computer.

The oscilloscope shows up in the device manager (PC Oscilloscopes-> PCSU200 Oscilloscope/Function generator) when I connect it to a USB-port, but the program seems unable to detect it. Options-> Hardware setup returns “No hardware response”.

  • I have tried different USB-ports, unplugging and re-plugging the cable both with the PcLab-software running and not.

  • I have tried uninstalling the PcLab software and installing the version I found on the homepage (https://www.velleman.eu/support/downloads/?code=PCSU200).

  • I have tried to update the driver for the oscilloscope, but the computer complains that “The required section was not found in the INF”… regardless of whether I let windows search for a fitting driver where it deems fit or if I tell it to look in the installation folder for the PcLab-software (C:\Program Files (x86)\Velleman\PcLab200\Driver).

Oh, and I’m running windows 7 professional sp1.

Hope you can help me.

Oh, and it has worked before, but it has resided in a drawer for some months now while I was working on other projects.

This indicates that the driver is properly installed.
The installation program pclab200_v1_07_setup.exe installs the driver automatically.
Can you test on another PC and possibly with other USB cable?

Yes, there is obviously a driver installed, but it is unable to update it, even though windows seems to find something to install (see pic).

Anyhow, tried another cable, but no difference :/.


Very strange…
I made a test:
First I selected “Update Driver”.
Then browsed to C:\Program Files (x86)\Velleman\PcLab200\Driver and click Next.
The result was: “The best drivers for your device are already installed”

Do you get similar info about the driver? E.g. Digital Signer: Velleman NV


No, Properties->Driver says that the driver provider and version are unknown (see pic).

When I try to update the driver, regardless of whether I tell it to look in C:\Program Files (x86)\Velleman\PcLab200\Driver or to search for a fitting driver it says that “The requred section was not found in the INF”

I downloaded the installfiles from your homepage just last week (same day I started this thread). Adding a pic of the properties of the driver file (presume this is the one).

Strange problem indeed…
The installation program pclab200_v1_07_setup.exe should install the driver automatically.
After running the installation program there should be in the Device Manager:
PC Oscilloscopes-> PCSU200 Oscilloscope/Function generator
The properties of this driver should be as seen in the screenshot I attached.
E.g. Digital Signer: Velleman NV
If not, then the driver is not properly installed.

I have removed both PcLab and the driver and reinstalled PcLab. Still no luck, now it doesn’t find any driver at all, and refuses to use the one in the PcLab-installation “Driver” folder. Still complains that “The required section was not found in the INF”. Same result when I tell windows to look for fitting drivers on the internet.

I have tried contacting Velleman, but they answer rarely, and when they do, seem to have not read the mail, but sends a general “have you installed the PcLab-software available on our homepage”… Well, yes, I have, a few times, and I specifically said so in the mail asking for help… And that mail took a week for them to send :frowning:

I mailed them again yesterday, asking if they might be able to send me the driver file by mail, since I seem to be out of luck with the one on the homepage. Still no answer, but I guess they will get a few more hours before I mail them again.