PCSU1000 - Open_USB_Device_By_Serial_Number - Invalid Handle


#1

Hello,

I’ve just bought your PCSU1000 scope but I’m having issues with the software.
When I launch PCSU1000 executable (either directly or thru the PC-Labs interface), the program starts to load but I get an error window with the message “Open_USB_Device_By_Serial_Number - Invalid Handle.”. No exit possible have to kill program.
I was able to launch it for calibration but second and successive launches always give the error. Un-install, re-installed, using latest version 3.02, no better.
I’m running Windows XP SP2 (with all MS patches) on an HP xw8000 PC. Looking at the Device Manager, I can see the PCSU1000 Oscilloscope device (no error).

What am I doing wrong ?


#2

Re-installing the program does not remove the scope settings file.
To initialize the settings go to the program folder and delete the WinDso.ini. Try then run the program thru the PC-Lab2000se interface again.

If no success then this may be some sort of USB driver problem.
Go to the Device Manager and delete the PCSU1000 Oscilloscope device.
Then unplug and plug the PCSU1000 and install the driver from the CD.


#3

Hello again,

Some more attempts.
I’ve rebooted my PC then was able to launch it. Made some measures which looked OK. But then the program did hang. Killed it then restart. At that time, the PCSU1000 program notified me that an other instance was already running (quit normal as I killed the previous instance - no chance to update running status). Asked to continue, but then the hardware (the scope) was hung too. Unplugged, re-plug. Appears to work again. But until when?
I feel that, in fact, I’m debugging this piece of software…

BTW, the Scope’s USB driver is latest version 1.6.20.0 and PCSU1000 is 3.02.

A frustated user


#4

Hello,

Our posts did cross…

I’ve uninstalled the USB driver, the PCLab2000 software. And redone the full install again (from the CD, then with the uploaded .zip files).
As said, after a reboot it looks to work a bit more. But then after few measures (some digital signals at 10kHz freq, not a big deal), the hardware/program hung.
I’m restarting it now and trying some more measures.


#5

More steps done.

I’ve uninstalled all related software (USB driver, PC-Lab). Remove the directories and then re-installed the latest versions only (not going to the steps of loading first the CD including in the box then upgrading).

Looks to work now.

Regards


#6

Thank you for writing here how the problem was solved.
This was strange problem indeed. It is not clear for me what might be the initial reason to it.
Anyhow, good that it is now solved and you got the oscilloscope and the software working.


#7

Hello,

In fact, I succeeded to get the software and oscilloscope running 99% of the time. I’ve no doubt that there were some “pilot’s errors” :slight_smile: However, there are still some situations (no clear context) where the scope hang and I need to disconnect it from the USB, to reset it, and then reboot my PC to free the USB handle… else I get the infamous error message in Subject of this thread.
Not very comfortable but I think I’ll have to deal with it until future software release (hopefully).


#8

It should run 100%.
Please inform if you get any clue about the situation where the scope hangs.
BTW: Do you have any other USB devices connected to the PC?


#9

Hello,

Yes I’ve the following USB devices:

  • Cordless keyboard/mouse
  • Scanner
  • Printer
  • Webcam
  • Joystick
  • USB key

Will try tomake note of situation for hangs.

Regards


#10

hi.

I have the exact same problem, the software does not work anymore
on my main workstation. I tried everything, uninstall, reinstall, old
version, last version…

I had to install it on an other computer.

I have several serial over USB devices on my main workstation.

Marc.


#11

I installed the software and driver correctly. but It did not work. I want to ask you to solve my problem. 22222-111111133333


#12

Can you test in other PC?