PCSU200 broken firmware?


#1

Hi at all,

Since this week i have a little problem.
My device is a PCSU200 digital oszilloscope.
I have programmed a microcontroller with my new programmer for microcontrollers. In the IDE of the programming tool, i have chosen the wrong port by accident. I think that has destroyed the firmware of my pcsu200.

Now i want to know, how i can update the firmware of the pcsu200.

Can someone help me to handle this?

Yours sincerely
kleinerkaktus

(I´m sorry for bad englisch. It´s not my first language. :wink: )


#2

That should not destroy the firmware.

Please try following:
Close the PcLab200 software if running.
Disconnect and reconnect the USB cable of the PCSU200 .
Run PcLab200 software.


#3

Hi,

thanks for your answer.
I have already tried this. Now I´ve seen another Problem. The software-driver had a problem.
I have reinstalled it, but it doesn´t help. MS-Windows says that everything is fine.

I don´t know what I can do. Do you have any ideas?


#4

When the PcLab200 is run, is there message “No hardware response…” displayed?
Doesn’t the USB cable disconnect/reconnect -> run PcLab200 again help?

What version of Windows are you using.


#5

Hi, yes there is a message like this. It also says that the software is running in demo mode.
I´ve already done this.


#6

Ah heey, now it´s running…
Don´t know where the problem was, but it´s working.
Tried it a few times and after the fifth try it is doing its job well.


#7

Nice to see that everything is back to normal now.