Printer connection problems


#1

!! HELP !!
I’m rather confident that the construction of my K8200 printer went according “to the book”.
Nevertheless it’s not working…
What is happening…
When I plug the USB cable from the printer (unpowered) in my laptop, both the green and red LED (close to the socket) are lit.
When I switch on the printerpower, both led’s turn off and the green led in the miccle of the board is pinking twice.
When I launche Repetier (version VO.95.F) the log windows says;
Open GL: extention 6LARB_color_buffer etc…
Open GL: rendering: Geforce 9600 GT/PCI/SSe etc…
Open GL: Using font VBO’s etc…

In section “Manual control” baudrate is set at 250000, com9 is active and reset… connect is Disbled.
There are no temperatures mentioned… 0°C

When I “connect” the printer;
echo: unknown command:""
echo: unknown command:""
echo: unknown command:"?"
The connection window stays blue colored, during the message “WAITING” the green LED (middle of the board) is pinking.
Next the message “WAITING” disappears and the window says “1 Commando expected”
When I introduce a munual command eg +Y(10) the blue window (top right) says “4 commando expected”.
In the mean time the printer is like dead…

What can I doe…?
Jean Burtin


#2

In the printer settings under Connection
For connector do you have Virtual Printer or Serial Connection?
Should be Serial Connection.


#3

Yep,
Serial printer was chosen…


#4

Is the firmware automaticaaly downloaded ?
When I switch on the message:
“FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup FIRMWARE_URL:http://www.K8200.eu - velleman.eu PROTOCOL_VERSION:1.0 MACHINE_TYPE:K8200 - 3D PRINTER EXTRUDER_COUNT:1”

is not showing in the log.
Can this mean something ?


#5

You should check to make sure Reset on Connect is set to Disabled.
Check the comport in device manager just to make sure you are the correct port.
Check the power supply for correct polarity and proper voltage at the blue connector you should see 15 volts


#6

reset is disabled,
com port is OK,
voltage is Ok (15 V)


#7

If you have another computer available try it on it or a friends computer.

You could try removing and reinstalling the driver.

Are you using the USB cable that came with the machine?
If so you might try a different cable.
If not try the cable that came with the printer.


#8

I’ve tried already two computers (Vista professional and Windows 7… same result… nothing happens.
I’m using the original cable .
To my opinion, the problem must be more fundamental… is there any quality control within the Velleman production chain ???
I’ve spent a lot of money to buy this thing !
If I could turn back time I would have bought an ready to use system, available for a little bit more money.
I WANT THIS PROBLEM SOLVED…???


#9

Is it possible to have someone from Velleman support helping me ??


#10

I’m sorry, you seem to be in a different timezone than us. The communication you are getting is not normal and has not been seen before. What we can suggest is reprogramming the controller board by performing a firmware upgrade.

Firmware upgrade instructions:
k8200.eu/manual/printing/?c=007

After that, we will have an idea if the firmware or the board itself is at fault. I am assuming that you followed all of the installation instructions (driver installation, printer settings configuration, etc).

If the board still behaves as it does after the firmware upgrade, I advise you to ask your distributor for a replacement controller board, under warranty.

All controller boards go through two steps of quality assurance before being packaged.


#11

Hi JeanBurtin,

Wrong Way’s suggestion to try different USB cables is a good point, often these cables cause problems since they tend to pick up interference that the USB chip on the controller board doesn’t like.

As you describe it, the printer startup is as it should be (LEDs lighting up etc.). The log entry “echo: unknown command:[…]” points to a pure communication issue. Please try to set a different baud rate in Repetier Host’s Printer Settings and test how the log messages change. This is the relevant setting, the baud rate for the COM port in Windows device manager can be left as-is.

Just to be sure - does any one of the ICs on the controller board get hot? Warm would be ok, but hot (say, above 50 °C) would point to a possible hardware error, which can of course also affect communication.

Cheers,
kuraasu


#12

Oh thanks gentlemen for helping me…
What bothers me is the fact that after connecting the printen, no firmware version is mentioned in the log…
I’ll try an other cable, and no, temperatures are absolutely normal.


#13

Gentlemen,
I’m living in (Mol) Belgium.
If it’s easier to communicate by phone, I’m willing to call anywere…


#14

Some more (maybe relevant information…?)

When I perform a reset on the printerboard, the log window shows;
echo: external reset
Marlin 1.0.0
echo: last updated Dec 26 2013 Author: Boris Landoni
compiled Dec 26 2013
echo: free memory 4300 Planner Buffer Bytes 1232
echo: Hardcoded Default Settings Loaded
echo: SD init fail
echo Unknown command "? "

ps I’ve tried an other USB cable… no changes


#15

After that reset, have you tried actually printing?


#16

Yes, nothing happened


#17

since this reset generates some remarks in the log area, may I assume that communication is OK ?
What does it mean SD init fail ?

Sorry for all this questions, but I desperately want to start printing…


#18

You connected, pressed reset, loaded an stl file, sliced it, pressed print and nothing happened? Nothing in the log, no errors, no nothing?


#19

It seems to me that SD Init should fail since you do not have a K8201 with an SD card. So this looks normal. You also seem to have working communication.


#20

I’m sorry but I did not try to print…
I still have to adjust the printer and therefore I need the manual controlls who are not working.
Can I try to send a sliced STL file to the printer knowing that thisone has not been calibrated.
Since the motors haven never been working I don’t even know that the endswiches are working properly.