Printer connection problems


#21

Hi JeanBurtin,

it could be a very small error, so it may be necessary to doublecheck the basic settings. For reference, here’s my (working) configuration on a Win7 (64 bit) system:

  • when connecting the controller board via USB cable, the “USB Serial Port (COMx)” shows up in the device manager. Driver version is 2.10.0.0 from FTDI, 27.01.2014. Connection settings there are 9600 bits per s, 8 data, no parity, 1 stop (aka “8 N 1”), and no flow control. Device status is “… working without problems” (or likewise, translated).

  • In Repetier Host, Printer Settings, Connection tab, options are: Serial connection, COM port matching the device manager, baud rate: 250000, transfer protocol: autodetect, Reset on C.: disabled, Emergency reset: send emergency stop + reconnect, Cache size: 63, ping-pong communication: off.
    Note especially the cache setting; iirc I’ve seen a version of RH, where the default setting was still 127 bytes.

  • Clicking the Connect button (still no power on the controller board), it should turn green, and the blue box in Manual Control tab should change from “Connecting” to “3 Commands waiting” or similar. The number should increase if you click any of the buttons below, e.g. plus 3 for any “arrow button” axis movement (XYZE), or plus 1 for all other commands. Controller board should still show two USB LEDs (red/green) constantly lit.

  • When switching on the 15 V power supply, the signal that you already saw should appear, i.e. USB LEDs going dark, LD1 blinking twice, then USB LEDs flashing fast during data transfer.
    Below the last log line (probably “Using fast VBOs for rendering …”) in RH, several new lines should be written, starting like

13:11:19.756 : start 13:11:19.756 : echo:PowerUp 13:11:19.756 : Marlin 1.0.0
Several errors may be present due to the commands waiting, mainly “Error:Line Number is not Last Line Number+1”; you can ignore those for the time being. Above the log, enable “Commands” and “ACK” to see all communication. With the regular temperature checking enabled in the Printer Settings (Printer tab), you should see M105 commands and acknowledgement-messages with the extruder and bed temperatures.

Probably, at some point your configuration will differ. Where?

Cheers,
kuraasu


#22

Gentlemen,
I’m happely surprised… my printer is working.
At least the mechanical movements are all there. Most probably it was the Cache setting from 127 to 63
which solved the problem.
Another couple of questions now…
while I was mounting the extruder, my “moment wrench” was set at 4.5 nM in stead of 3,5, so I’ve broken the
brass extruder peace.
Question; how and where can I get a new one ASAP ?
What do I do to switch from PLA to ABS ?

Thanks very much for helping me out gentlemen !


#23

You can order a replacement part from your shop


#24

Since you are just starting PLA would be the best choice since it is more forgiving.


#25

Could you post a screenshot from your printer settings?

Best Regards,
VEL337


#26

My printer is working now,
so problems are solved

Many thanks to all of you…


#27

Good to hear =)

Happy Printing !

Best Regards,
VEL337


#28

I experience the exact same problem, I thought it had to do with Linux comms, same problems as described, tried to upload the firmware, got a message that the board was not ATmega2560, that was yesterday. (DID try all the other reset on connect options, not ‘disable’ tough LOL)

The Repetiersoft on my Win7 reacted in the same way as on my Linux desktop.

I’ve disabled the ‘reset on connect’ in the printer connection tab this fixed the problem, so printerwise all seems well.

Kind regards