Problem uploading to board


#1

I am installing my VR408 very slowly in order not to miss things out.
Now I am stuck with an error message from the upload that makes it impossible to get
the sketch uploaded.
It happens whith the VRSSM and the VRBS1 shields mounted.
I run the “Center Sensor” sketch and the verify runs fine but when I try to upload
it I have a number of lines like these two:
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
and then it stops with “avrdude done. Thank you. Problem uploading to board”

If I upload without the shields mounted it runs fine and I can afterwords mount
the shields and when I switch the blue leds on the function is performed.

I can not figure out what the avrdude is or what it adds to the system. It seems to
be i connection with one or both shields.

Thanks in advance for good ideas.

/Gunnar Ståhl


#2

Check the switch on the servo shield. It should be on Program if its on Receive IR, you can’t program the arduino


#3

So unbelievably embarrassing !!!
I was (and am) so very much aware of that swich and its functionality and still I made the mistake
not to check its position. Despite many attempts to try the upload and manual studies.


#4

Haha :slight_smile:

Glad it’s working now.


#5

So unbelievably embarrassing !!!
I was (and am) so very much aware of that swich and its functionality and still I made the mistake
not to check its position. Despite many attempts to try the upload and manual studies.

O’boy Aren’t you quick
Sorry. The first quote ran out of my fingers by mistake
Anyway. Thanks a lot and sorry for taking your time for such a bad reason.
I’ll probably go to bed again. :frowning:

Gunnar Ståhl


#6

Hallo,
ich habe einen VR 408 und suche seit mehreren Tage auf ihrer Seite die Software, welche ich in die Bibliothek einbinden soll.
Den Sketch auf ihrer Seite habe ich mehrfach versuch zu kompilieren. Jedes mal kommt folgende Fehlermeldung:

C:\Users\Gonter\Documents\Programmierung für ALLBOT\Arduino\Sketch\VR408Scratch\VR408Scratch.ino:23:139: fatal error: SerialALLBOT.h: No such file or directory

compilation terminated.

exit status 1
Fehler beim Kompilieren für das Board Arduino/Genuino Mega or Mega 2560.

Wo finde ich die Software, welche ich in die Arduino-Bibliothek einbinden soll?

Danke
MfG
Rene


#7

Please post in English.
But have you copied the contents from “Documents\Scratch programming for ALLBOT\Arduino\Library”
to “Documents\Arduino\libraries\ALLBOT” ???
See the manual:

FIRST USAGE
Before you can use Scratch, your Arduino board needs to have the ALLBOT Scratch Sketch programmed, if this is already done, continue to the Usage section.

  1. Make sure you have installed the latest Arduino version https://www.arduino.cc

  2. Copy the ALLBOT Library from “Documents\Scratch programming for ALLBOT\Arduino\Library” to your Arduino installation directory\libraries\ALLBOT

  3. Connect your ALLBOT to your computer and wait a few seconds to ensure that a proper connection has been established and the serial port is initialized.

  4. Open the Scratch Sketch for your ALLBOT, which can be found in “Documents\Scratch programming for ALLBOT\Arduino\Sketch”

VR408 Scratch - for the 4 legged ALLBOT with 8 servo’s

  1. Upload the Sketch to the Arduino

#8

Hey VEL337, I have almost the same problem. The difference is that I copied the ALLBOT Library from “Documents\Scratch programming for ALLBOT\Arduino\Library” to my Arduino installation directory\libraries\ALLBOT. Now Arduino say when I want to upload the Sketch : “”"

In function ‘operator delete []’,

inlined from '__base_dtor ' at C:\Users\radiac\Documents\Arduino\libraries\ALLBOT\src\SerialALLBOT.cpp:13:11,

inlined from '__static_initialization_and_destruction_0(int, int) [clone .part.0] [clone .constprop]' at C:\Users\radiac\Documents\Programmation Scratch pour ALLBOT\Arduino\Sketch\VR408Scratch\VR408Scratch.ino:14:14,

inlined from '__static_initialization_and_destruction_0.constprop',

inlined from '_GLOBAL__sub_D_BOT' at C:\Users\radiac\Documents\Programmation Scratch pour ALLBOT\Arduino\Sketch\VR408Scratch\VR408Scratch.ino:696:1:

C:\Users\radiac\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.21\cores\arduino\new.cpp:34:12: warning: attempt to free a non-heap object ‘BOT’ [-Wfree-nonheap-object]

free(ptr);

avrdude: ser_open(): can’t open device “\.\COM13”: Le fichier spécifié est introuvable.

“”""
Do you know what’s the problem ?
Thanks


#9

This is your problem, Arduino can’t find your board.
Is the FLASH/IR RECEIVE switch correctly set?
Is the correct COM port selected?
is the correct board selected?


#10

Yes everythings is ok the arduino is detected and I selected the good Com port and the correct board. I have also this message


#11

do you know what’s the problem with this library ?


#12

Because it’s clearly the library who have a problem. When I move the Serial_Allbot library from the others library and then I put the exemple program (not scratch program) on the Arduino it’s work.

EDIT: it’s ok no problem now with avrdude, the software compiles fine. But nothing is happening on scratch when I press on the keyboard.


#13

That’s a warning. That’s not an error you can ignore that.
Like i said, you see the error that you can’t upload the sketch. So the software compiles fine.
There must be something else.

EDIT: just tested it, i get the same message but is working fine.