Problems PCLAB2000 LT with Windows10 Professional


#1

Hi,
I have a PCSGU250 PC oscilloscope, I installed the win8 driver carefully under WIN10 PROFESSIONAL, as described on the web, and it is OK in the devices management (no driver issue, and product is recognised as “PCSGU250 Oscilloscope/Function Generator”.

However, PCLAB2000LT doesn’t work at all.
I tried on another machine running under WIN10 HOME EDITION, and it works OK.
Would someone have an explanation and solution to this ?

Many thanks,


#2

Did you go in to Options --> Hardware and set it for PCSGU250?
3067


#3

The problem is that the software doesn t work
When I launch it I have no window at all …


#4

Just a guess.

Was you computer set up with 2 monitors at one time?
If so the window maybe on the other monitor that is no longer there.
You may need to connect another monitor and move the window back to the primary monitor.


#5

Good idea, but unfortunately, I tried to re-install the software with one single monitor, and the situation is still the same.
After a certain time, I have the following messages :
“Access violation at adress 004E8C8F in module ‘PcLab2000LT.exe’ . Read of adress 00000047”
and another window with the message “Unable to assign “ALT+B” as hotkey”


#6

This indicates that other software is using the “hotkey” feature.
You can ignore this message.
To refresh the software settings please select File ->Restore Default Settings & Exit


#7

OK it sounds as if you did have 2 monitors at one time.
Try opening PCLAB2000LT.
After it opens hold down the shift key and right click on it in the task bar left click on “Move”
Use the arrow keys to move it back on to the screen.
Sometimes even when you remove the software and reinstall it the window will stay on the 2nd monitor.


#8

I think you’re right, it seems that the bug was linked to multiple monitors (I have 3 !). I finally reinitialised Win10, and all worked OK. Then I “played” again with my monitors, and lost the window again…
It is back now, and all works OK
Many thanks for your help anyway !!

Best regards,


#9

I wish I would have posted that answer yesterday so you didn’t have to go through all of that.
Glad to hear you are up and running again.


#10

The old size and position are still remembered in PCSGU250.ini file.
By deleting the PCSGU250.ini file, all the settings are set to default.
In Windows 10 the file is located in the folder: C:\Users<username>\AppData\Local\Velleman\PCSGU250