Ran out of filament, printer kept going. roller doesnt register

While I was printing I ran out of filament and the printer did not stop (as it was supposed to). I dont really know how to get the filament out at this point. The unload function of the printer does not seem to do anything. It is stuck. The filament is in the tube, but I think its not being grabbed by the rollers that are meant to push it back out. Any ideas on what I can do?

Edit: I have a vertex delta, that could be inportant here.

You can try loading another piece of filament, in hopes that it will push the broken remnant down the tube to the extruder. If that doesn’t work, you may need to disconnect the tube from one end to grab the filament and pull it out. (Remember to heat the extruder before you attempt to extract the filament.)

Good luck!

I wish I could pull it out, even from the roller at the top it just slips between my fingers… I dont currently have another roll of filament. Should I try disconnecting it or just wait for the new filament?

Also, doesnt this mean the sensor doesnt work and might be broken?

If the extruder is not heated, you won’t be able to pull the filament out.

The filament run-out sensor should probably have stopped the printer before the filament went too far into the machine. It has an LED on it to indicate whether it detects filament. You can test the sensor by sticking a piece of filament into it and watching the light.

Some of these sensors are a bit finicky, or you may have filament that is not uniform in diameter. There are a few threads here on the forum from people who have re-touched the solder on their sensors, etc., to fine-tune its performance.

The indicator is probably located on the left of the printer? on the entrance of where the roller pulls in the filament

There should be an LED near where the filament enters the drive block. (The part with the motor in it.)

Disconnect the tubing on the extruder.
Heat the print head push a little filament then pull it out.
If that doesn’t work the dis connect it on the print head and try it there.

I was trying this. bit Im scared of ripping out the cables. I am having to apply some serious force to get that tub out. its kinda stuck…

Before you pull push back on the red ring around it.
That will unlock it.

1 Like

I did not think about that. Holy crap that worked miracles

It took me a little while to figure that out too.

I was pulling for dear life, not getting any results… That worked. I am going to keep that in mind for the future, also for cleaning the nozzle. since it is the same mechanism…