Sudden bad bed adhesion using 0.05 mm profile

So somehow I suddenly started getting bad bed adhesion using the 0.05 mm on Cura, had plenty of great prints before though and now it just stopped adhering, the 0.2 mm one still prints fine, although the initial bed layer height is the same on both, with 0.2 mm layer height, what the ****?

Attempt with 0.05 mm, was struggling very much to get it to adhere, barely any adhesion to speak of anywhere.

I noticed that the line widths were bad, way too small for what they should be, also the material somehow doesnt stick to the plate anymore much (gets stuck easily to the print head while it is printing).
So i tried scaling up the model to 150%, changed the resolution to 0.1 mm, and forced a line width extrusion rate for initial layer by 200%.

Worked better, but makes it even more obvious the line width calculation is way off. Interestingly the extruder gives no clogging sounds whatsoever, since a clogged nozzle would be my first guess. Still the adhesion is lacklustre, part I tugged away is what lost adhesion almost immediately while printing the supports. At least now some force is required to pull the print loose from the bed.

Now initial layer (with a bit of second) with 0.2 mm setting. 100% initial layer width, perfect adhesion, hard to remove, you can see the line widths and flow were calculated just perfectly fine. THESE INITIAL LAYERS SHOULD HAVE BEEN ALMOST IDENTICAL. I always have my initial layer set to 0.2 mm, so why on earth is it failing on the other settings now all of a sudden?

So I investigated the Gcodes of 0.2 layer height vs 0.1 layer height

0.2 mm:

0.1 mm:

And to me it seems like Cura is suddenly failing? Halving the extrusion amounts for what should be the same layer.