Vertex Delta nothing but problems

I’ve had a delta since just before xmas and it is easily the most unreliable swear inducing machine I’ve ever encountered!!!

Where to start:

Assembly went reasonably well except bizarrely one foot has too small a thread both of the other two will screw in perfectly to all three positions so it’s definitely a dud foot!

Filament detection is random at best brain dead at worst I suspect the hardware so simply disabled it as seems a bit of a silly feature anyway.

Bed adhesion rarely tolerable, tried ensuring no drafts, tried using a brim but then PLA falls apart when trying to remove it, buildtak seems to be part of the problem rather than the solution pritt stick being infinitely more reliable!

However none of this is the big problem: the piezos seem totally random sometimes work sometimes don’t, anything less than max sensitivity is pointless as the head just crashes either when calibrating or when levelling. I made sure the bed wasn’t too tight by adjusting one tab as per the troubleshooting, it worked for a while but then back came the problems.

I bought a new bed and buildtek thinking that possibly that might help as the old surface is now looking battle weary… but what a waste of money the new glass bed is so much bigger I had to trim ALL 3 retainer tabs and still it’s not yet free! Yes buildtek trimmed all the way around (what a useless design it is!!!) so it’s the glass that’s the problem… how can I adjust that???

So now I have a bed that is loose and another that is too tight, great!

As an aside the magnets on the arm rods seem woefully weak or is this intentional so that when all these other problems arise the whole contraption just collapses?

Starting to wonder if the Delta is a prank??? :slight_smile:

I’m so hoping this can be fixed though!

Lawrence

Dear Lawrence,

For the calibrations issues, please check all these steps: https://manuals.velleman.eu/article.php?id=789
=> Follow: Calibration issues.

For the glass panel, feet (foot too small thread), place here a ticket https://customercare.velleman.eu/ so we can help you further there.

If parts are not okay when following problem solution mentioned above. You can also post on the ticket system.

Regards,
Velleman Support