VM205 does not work


#1

Got a VM205 scoop/analyser. Installed both hard- and software on a pi 2 b as described in the manual but no joy. Starting the software gives a screen with two parts. The third part is simply not there. Maybe the hardware is not seen? Anyone seen this before? Is there a cause and - more important - a solution of this problem?

Some details:

version vm205_src_pi_rev12
spi enabled
/etc/modprob.d/raspi-blacklist.conf is empty

petrus bitbyter


#2

[quote]Starting the software gives a screen with two parts. The third part is simply not there.[/quote] This happens if the aspect ratio of the monitor is 16:9.
Using aspect ratio 4:3 the user interface of the VM205 software fits on the screen.

Here you find instructions how to change the aspect ratio:
raspberrypi.org/documentati … fig-txt.md

See the chapter “WHICH VALUES ARE VALID FOR MY MONITOR?”.
Select the high resolution DMT supported mode of your monitor with aspect ratio 4:3.


#3

Thanks for your reaction, but…
I tried several monitor settings according to your advice but no result. Then digging on the attic I found on old PAL monitor/tv. After solving the wiring issues the monitor does well on the Raspberry but still no control screen of the VM205. (Of course the picture quality is poor compared with todays standards.) So what more can I do?

petrus bitbyter


#4

I’m sorry, it seems the user interface of the VM205 software doesn’t fit on the screen of your monitor.
The minimum vertical number of pixels should be 655.
E.g. resolution 1024x768 will be OK.


#5

Thanks again. I forced the frame dimensions to 1024x768 but only got a little more image on the right side. Nevertheless it looks like there was more of it hidden so I forced the frame to 1920X1080 and got the whole picture. Strangely enough it occupies only about 21x16cm of the available 35x25cm window. Maybe it can be improved by rewriting some of the source code. For now I’m going to investigate the (mis)behavier of some rotary encoders. So thanks once more.

petrus bitbyter


#6

[quote]I forced the frame dimensions to 1024x768 but only got a little more image on the right side.[/quote]This is strange. I got the whole image using this resolution…

[quote]Strangely enough it occupies only about 21x16cm of the available 35x25cm window. Maybe it can be improved by rewriting some of the source code.[/quote]Yes, this can be done in the future releases.