Work LED's off all the time

Hello all,

Newbie here, I’m using my K8800 with Octopi, which has been an awesome combination, however; is there a way in gcode or something to tell the K8800 to ALWAYS keep the LED’s powered off? I’m using a camera and with the LED’s on there’s just too much glare off the bed so the camera sees nothing but light (I’ve also tried a number of cameras, same result). [edit] It’s currently working on a small project, you can see in the photo that with the work lights on (which come on automatically) you can see nothing.

I’ve turned them off on the printer, saved the config but this doesn’t seem to help at all. They always come on when items are printed.

Thanks in advance for any advice2020-01-19 11_56_44-Rob's Octoprint OctoPrint

I think I’ve figured this out … I’ve changed the default machine code in Ultimaker Cura (but should work elsewhere), in the default start code I’ve added one line to kill the lights: The end of the start code for me now looks like:

G4 S2 ; Wait 2 seconds (Changed this to shorten the delay)
M355 S0 ; Turn off LED's
G1 Z15 F2000 ; Changed this to stop the hot end dragging the purge blob into the job
G1 X0 Y85  F2000
M117 Vertex Delta printing

The line for the lights is the M355 S0 line… other changes from default were a result of another thread where the hot end was dragging the purge blob off the bed and into the job as it started.

1 Like